Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today, I recieved a shiny new Blue Yeti Pro USB microphone in the mail. I did my research to make sure that it would work. I found the following websites, and this is what led me to believe that it would work without any issues, despite the fact that it is a USB 2.0 device:

http://community.linuxmint.com/hardware/view/12511

http://geardiary.com/2011/06/28/revi...hone-yeti-pro/

So- I got it out and plugged it in. The red light on the mute button lit up and started flashing, which means that the Mic is muted. I un-muted it- so far, so good. I went to the sound settings menu. It was recognized as: Digital Input (S/PDIF) BLUE USB Audio 2.0 and BLUE USB Audio 2.0 Analog Stereo. I tried to select them, one at a time as the input device. Each time I tried to select it, the sytem settings would crash and shut off.

Then, I tried to select it using JACK instead. In Jack, I was able to select it as the input device without issue. I fired up the JACK server and didn't get loads of xruns, so I opened Ardour. I couldn't get signal flowing in to Ardour no matter what I tried. Now It's getting frustrating. I shut off the JACK server and decided to try something else. So next I open a terminal and fire up

alsamixer

and got similar results, the microphone is recognized and I selected it as the sound capture device. The levels look good so I open Audacity and select the microphone as the capture device in Audacity. The same thing happened- no audio signal was getting in to the computer.

So, I decided to try installing and running

pavucontrol

. The microphone is recognized. Great. I can select it. Great. I fire up audacity again and the same thing happens- no audio signal to the computer. The next thing I tried was killing pulse and just using ALSA. I tried bothpactl exit

and

pulseaduio --kill

and try selecting the microphone again with alsamixer- same result each time, no signal to the computer.

At this point, I'm really frustrated. I tried making sure of the the dumb stuff, like "is it plugged in" and "maybe I should try the other USB ports". No dice. I tried the direct headphone monitor on the mic to see if it's picking up sound at all, and it is. I'm completely baffled. when I run

lsusb

in a terminal I get the following output:

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 003: ID 13d3:5710 IMC Networks Bus 002 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver Bus 002 Device 006: ID 074d:0002 Micronas GmbH I uplugged it and ran

lsusb

one more time to see which device it was for sure. It's the Micronas GmbH device. At least that's some information. Then I rancat /proc/asound/cards

and got the following output:

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                  HDA Intel PCH at 0xdfc00000 irq 52
1 [B20            ]: USB-Audio - BLUE USB Audio 2.0
                  BLUE BLUE USB Audio 2.0 at usb-0000:00:1d.0-1.2, high speed

Also, when I open the System Settings from the Terminal with gnome-control-center I get the following output with regard to audio:

(gnome-control-center:3593): sound-cc-panel-WARNING **: active_output_update - couldn't find a stream from the supposed active output
(gnome-control-center:3593): sound-cc-panel-WARNING **: active_input_update - couldn't find a stream from the supposed active input

When I try to select my microphone, the System Settings Window still closes and I get this in the terminal:

Segmentation fault

Maybe there's something useful there?

So- that's what I've got. A pretty sweet microphone that would be a really useful tool if it worked. I thought it would, and it doesn't. I am completely perplexed and don't know what I should do next. Does anyone have any ideas or advice?

share|improve this question
    
Here's some more information. When I open the System Settings from the Terminal with gnome-control-center I get the following output with regard to audio: (gnome-control-center:3593): sound-cc-panel-WARNING **: active_output_update - couldn't find a stream from the supposed active output (gnome-control-center:3593): sound-cc-panel-WARNING **: active_input_update - couldn't find a stream from the supposed active input When I try to select my microphone, the System Settings Window still closes and I get this in the terminal: Code: Segmentation fault Maybe there's something useful there? –  user166181 Jun 11 '13 at 4:21
    
Also, the microphone appears to work fine with a 12.04.2 live DVD but not with a 13.04, Linux Mint 15 or Mint Debian edition live DVD- is there a way to roll back the driver to the previous version so I don't have to reinstall my whole OS?? –  user166181 Jun 11 '13 at 5:06
1  
I researched this issue extensively when using my Blue Yeti, and it turns out there is a bug in the driver. I was hoping it would be fixed by now. Try using arecord /path/to/file.wav from a terminal. Speak into the mic while it's running. Press Ctrl+C to stop it from recording. Did anything happen? –  Freedom_Ben Jul 8 '13 at 15:02

1 Answer 1

Since posting this question I have found a solution!

When Using JACK and Bitwig studio on 14.04, I was still getting the same behavior. It worked the first time, but was automatically muted for capture on subsequent reboots. I am able to unmute the capture card using QasHctl now, where I was not able to do so in the Ubuntu Sound Settings Menu or Alsamixer.

That's it. Just unmute the Yeti Pro Capture card in QasHctl. Problem Solved!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.