Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I already have the ia32-libs installed and i used this code

sudo apt-get install ia32-libs

anyone have any suggestions on what I'm doing wrong?

share|improve this question
    
That depends entirely on what it actually is that you are doing, which you haven't described. –  psusi Jun 10 '13 at 18:04
    
@psusi This already has an accepted answer. –  belacqua Jun 10 '13 at 18:42
add comment

1 Answer 1

up vote 2 down vote accepted

LAMP is a software bundle for Linux that includes Apache, MYSQL, and PHP.

To install LAMP you need to do the following:

install apache:

sudo apt-get install apache2

Optional: Testing Lamp: http://localhost/ in your browser

install and restart Apache:

sudo apt-get install php5 libapache2-mod-php5
sudo /etc/init.d/apache2 restart

Test PHP if you like:

In the terminal copy/paste the following line:

sudo gedit /var/www/testphp.php

This will open up a file called phptest.php.

Step 2. Copy/Paste this line into the phptest file:

<?php phpinfo(); ?>

Step 3. Save and close the file.

Step 4. Now open you're web browser and type the following into the web address:

http://localhost/testphp.php

Install MYSQL:

sudo apt-get install mysql-server

gksudo gedit /etc/mysql/my.cnf

Change the line bind-address = 127.0.0.1 to your local IP. This will enable other computers on your network to see this computer, this step is optional.

This is where things may start to get tricky. Begin by typing the following into Terminal:

mysql -u root

Set root password

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('yourpassword');

(Make sure to change yourpassword to a password of your choice.)

Install phpMyAdmin which is an easy tool to edit your databases. Copy/paste the following line into Terminal:

sudo apt-get install libapache2-mod-auth-mysql php5-mysql phpmyadmin

Make PHP play nice with each other:

gksudo gedit /etc/php5/apache2/php.ini

Now we are going to have to uncomment the following line by taking out the semicolon (;).

Change this line:

;extension=mysql.so

To look like this:

extension=mysql.so

Restart Apache one last time

sudo /etc/init.d/apache2 restart
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.