Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i was using Fedora for about six months. Recently I have been changed to Ubuntu. And here in Ubuntu, there is no Code/Synatax for groovy in VI editor,which was actually there in Fedora VI. How to enable that?

share|improve this question
    
thank for your reply :) – Ant's Mar 18 '11 at 15:36
up vote 2 down vote accepted

to enable syntax highlighting in vim you have to enable it thrugh vimrc. add

syntax on

to your vimrc. here is the typical script for groovy. I donot know if it is compatible with vi or not because I am also novice to vi/vim. You can install the full vim with

sudo apt-get install vim

share|improve this answer
    
No, this is not enough – I follow instructions on vim.org/scripts/script.php?script_id=945 and still not working :-(. – pevik Nov 23 '15 at 11:31

or in vim editor type:

:syn on

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.