Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using awesome wm on a ubuntu 12.04. It works fine except that whenever I run guake or nautilus should the background being reverted back to what's my background on unity.

on using nautilus, there's a simple workaround that I've found here

Problem with Nautilus when using awesome

But is there a permanent configuration to set here so as to not conflict with awesome?

But I haven't found a solution yet when using guake.

share|improve this question

3 Answers 3

You could modify the /usr/share/applications/nautilus.desktop so it says in the line

Exec= nautilus --no-desktop

It should be the third line

share|improve this answer
    
sorry didin't seem to work –  jaorizabal Jul 14 '13 at 17:21
    
thanks for your answer. i've tried it. But it doesn't work –  chanHXC Jul 30 '13 at 14:27
    
you could also try the prized solution, sorry for commenting that late –  Ubuntubro Apr 20 at 13:57
  1. Install dconf-tools

    sudo apt-get install dconf-tools

  2. Open dconf-tools

  3. Search for org > gnome > desktop > background

  4. uncheck "draw-background" and "show-desktop-icons"

Good Luck!

P.S. I have no experience with awesome wm and cannot test my solution, but I really think this should solve your problem. I am sorry in advance to steal your time if it does not work.

[edit]I overread the Guake Part of the question. I am not sure if you want the Unity background or not, but there is "Guake Preferences" installed with Guake, where you can set a background or switch transparency off to get what you want. or not?[/edit]

share|improve this answer
    
thanks for your answer. but i've tried all the steps but still the problem occurs. –  chanHXC Jul 30 '13 at 14:28

I realise this post is rather old but I just thought of a possible permanent configuration. Although this looks like and probably is a workaround it should fix your issue permanently, that is, if you are launching nautilus with the nautilus command.

alias nautilus='nautilus --no-desktop'

I do not know about guake.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.