Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ASUS-K55V. I had a dual boot with Windows 7 and Ubuntu 12.10.

Recently I upgraded my Ubuntu from 12.10 to 13.04 using the do-release-upgrade command. The update went fine, but after the update when i tried to boot into windows, it gave me an error, and restarted. Then i used a windows installation USB and used the repair commands

bootrec /FixBoot  
bootrec /FixMbr

When my machine booted this time the grub menu didn't show up, so i used a live Ubuntu USB to recover my Ubuntu. I used the boot-repair tool suggested at Ubuntu Sharing.

Now I got my 13.04 back and i ran the update-grub2 command to recover my Windows, but it does not detect Windows 7 now. I tried using my Windows 7 Installation USB to use the Repair option, but even there it does not detect Windows 7.

Next I added the boot option myself by the procedure given at this Post, and this Post, yet there is no menu entry for windows in my grub.

Please help me to fix this issue.

share|improve this question
1  
Are you sure windows still exists? And please post the output paste that boot repair gave. It contains some useful info that we can use to help you. –  DaboRoss Jun 10 '13 at 2:40
add comment

1 Answer 1

My first thought is perhaps it's a UEFI motherboard (these are common within the last few years). Do you know how recent/which motherboard it is? If it is, a Windows 7 CD (perhaps borrow one if you don't have one) should autofix the boot record (it auto-detects on CD launch) and then you can use EasyBCD to add an Ubuntu boot record via their "Auto-detection" EFI loader.

If it's not UEFI, this answer may not help. The only other thought I had was use grub-mkconfig to make a new grub config file. Grub has a mode to auto-detect installed OS's. Best of luck

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.