Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I was trying to resolve a longstanding annoyance, the fact that changes I make in CompizConfig Settings Manager do not persist after a reboot. Googling around, I saw that this appears to be a current bug, but one person claimed to have fixed the issue by going into CCSM's Preferences, then changing "GSettings Configuration Backend" to "Flat-file Configuration Backend".

That seemed like a harmless enough thing to try, so I tried it. Immediately after selecting the flat-file option, Unity died. I was left with only the unadorned windows of programs I was running at the time. I tried rebooting, but came back to a desktop with Unity still dead. Fortunately one of my desktop icons is for my web browser, so I was able to start searching for a fix.

After some fruitless twiddling in /etc/compizconfig, I was able to launch CCSM from the command line and reverted the option that had caused all the trouble, but Unity stayed dead. Eventually I read that I needed to enable the Ubuntu Unity Plug-in. I did so (not that I'd ever disabled it), and was asked if I wanted to enable various other plug-ins, to which I naturally agreed. Another reboot later, Unity was back! Sort of. The launcher and desktop title bar (or whatever it's called) were back, but now whenever I start an application, the window appears in the upper-left corner of the screen, partially obscured by the launcher and title bar, and it doesn't sport any of the usual window manager dressing that would enable me to move it around, resize it, etc.

And here I'm stuck. Any help getting the rest of the way to a working desktop would be much appreciated.

(Unity does seem awfully fragile. Last week I tried to unmount my iPhone by right-clicking on its launcher icon and choosing "Unmount," and that killed Unity too somehow. In that case, however, a reboot brought it back.)

share|improve this question
1  
What version of Ubuntu? (12.04, 13.04) What version of Unity? (current, beta, etc.) –  david6 Jun 10 '13 at 1:44
    
Ubuntu 12.10. 64-bit, if it matters. I don't know what version of Unity; how would I find out? I'm just using a stock Ubuntu install with all packages up-to-date. –  Sean Jun 10 '13 at 1:59
    
I suggest resetting Unity. See askubuntu.com/questions/17610/…. –  DaboRoss Jun 10 '13 at 2:00
    
And you can tell your version of unity with unity --version –  DaboRoss Jun 10 '13 at 2:00
    
unity --version tells me unity 6.12.0. –  Sean Jun 10 '13 at 2:01

1 Answer 1

up vote 0 down vote accepted

Reading further down the askubuntu page referred to by DaboRoss above, I found the answer titled "For Ubuntu 12.10 (Revised, again)" which said to run the command

dconf reset -f /org/compiz/

That worked, or at least nothing bad happened, but when I followed it with the next command

compiz --replace & disown

...Unity crashed hard, again. But this time, when I rebooted, everything was finally back to normal.

Man. Henceforce I will exercise much more caution when executing potentially perilous actions, like changing settings in CompizConfig Settings Manager.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.