Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Gdebi apparently doesn't install recommend packages by default, it only installs dependencies. I tried

sudo gdebi -o="--install-recommends" package.deb

but it doesn't work.

How to install also the recommend packages using gdebi?

share|improve this question

2 Answers 2

If you are using a package manager to install packages, you will have manually gather the depended debs and add them to the command line. The package manager will respect dependencies, but will only search the packages available on the command line.

Instead of using a package manager to do the installation, it would be better to use a more Advanced Packaging Tool that has knowledge of a repository of packages that can be searched for the dependencies and list them on the command line along with the package you desire to install. This is what apt does for you. It gathers the dependencies of packages selected to be installed and hands the list over to dpkg.

My solution would be to just run dpkg -i package.deb and watch it fail. Then run aptitude and it will complain about broken packages. Follow the instructions in red at the bottom of the screen and select a solution that best fits what you need.

share|improve this answer

The -o option of gdebi is not meant to pass command-line options to apt-get, but configuration options. Thus, to install recommended packages, you should use:

gdebi -o "APT::Install-Recommends=1" ...

Since,

  1. man apt-get says:

    --no-install-recommends
       Do not consider recommended packages as a dependency for
       installing. Configuration Item: APT::Install-Recommends.
    
  2. From How not to install recommended and suggested packages?,

    The correct syntax in recent versions appears to be:

    APT::Install-Suggests "0";
    APT::Install-Recommends "0";
    
  3. And comment #7 on this Launchpad question says:

    For anyone googling, I can't give the correct format for APT::Get options, however the following worked for me for APT::Install- options.

    gdebi -o APT::Install-Recommends=0 -o APT::Install-Suggests=0 .....
    
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.