Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been working on my gpu switching system for a while. I have recently decided to stick with the open source driver. Those drivers were taken from the repo of Xorg edgers. OK, i have followed all the instructions given by Ubuntu and I have also made the script Ubuntu is talking on his official page but there is something wrong with the switching. It seems that when I which to switch to the discrete GPU, the power is on for both card and the mark is on the integrated card. if I choose the integrated card the discrete goes off and the marker remains on the integrate card(obviously). I have noticed that when I switch with the script I,ve got this message saying switching to a specific card. when it comes to the integrated, the first time it says that it switches then it saws that it already switched which is different for the discrete. it keeps saying switching to.... I've got a AMD Radeon hd 7730m with an intel hd 4000 running with Ivybridge.

share|improve this question

1 Answer 1

I didn't get a correct switching between my ATI and my Intel graphic cards with the open source driver. The only thing that I got was disabling the discrete graphic card with switcheroo command.

The only way that I got both graphic cards working and switching as I wanted was installing the latest privative drivers from AMD (http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx) and following this tutorial: What is the correct way to install ATI Catalyst Video Drivers (fglrx)?

I hope that this helped you.

share|improve this answer
    
the problem with proprietary driver is that they seem to be not compatible with my card. I've got a lot of problem to make them run and I have a lot of problems with them when I try to make a game or a graphic software run correctly. –  Jeff Labonte Jun 10 '13 at 0:43
    
Then, the only thing I could say then is to disable discrete card as here specify: askubuntu.com/a/221767/153260 If you don't want to do this always you turn on your computer, you can add this to the local.rc file. –  Leo Jun 10 '13 at 7:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.