Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question has perhaps been asked before but no clear solution seems to exist for me. I have a Radeon 6850 connected to my screen via HDMI. The picture is fine but I get no sound at all, not even sound effects.

This is via open source drivers. According to X.org Foundation website, it says HDMI audio is "Done." I get no sound using my extra speakers with 3.5mm jack either into the motherboard itself or in the monitor. The pavucontrol seems to recognize both the built-in sound card and HDMI card from Radeon, with the progress bar reacting to the Youtube video currently on.

Switching between built-in card and HDMI doesn't work. Other things I've tried include downgrading to 12.10, adding the xorg-edgers ppa, manually updating the kernel to 3.9, adding the radeon.audio=1 to grub, and downloading an ALSA update from Ubuntu Audio Development Team.

The only thing that has worked is installing fglrx, but that makes my emulators crash sometimes. Attached here is the lspci and aplay output...

amd-fx@amd-fx:~$ lspci | grep -i audio
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)

01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Barts HDMI Audio [Radeon HD 6800 Series]

amd-fx@amd-fx:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****

card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Any help is appreciated. Thank you.

share|improve this question
add comment

1 Answer 1

If you're using a kernel version less than 3.10.1 and you can upgrade to that or a later version, that may solve the problem.

I had the same exact problem, and after updating the kernel, my problem is gone now. (Though problems with the fan spinning all the time remain.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.