Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everyone else in the world seems to be able to play steam games in wine just fine, except for me. I am running a brand new Nvidia GeForce 670, I have a quad core i7 920 2.67GHz, and 11GB DDR3 RAM.

Counter-Strike: Global Offensive, runs choppy in wine Left 4 Dead 2, runs choppy in wine Counter-Strike: source, runs choppy in wine

Even the native games such as Left 4 Dead 2 Beta and Team Fortress 2 run choppy in wine. Counter-Strike: Source natively runs good.

For the record, ALL OF THESE GAMES run 100% with excellent frames in windows 7 on this same computer.

I have tried all of the proprietary drivers, and I am currently set to 313. Am I doing something wrong? A bad wine setting? Keep in mind my wine drives are being set up by playonlinux.

If anyone can help, THANKS! I do not want to go back to windows, but it's looking like this linux thing is just an uphill battle that still ends up with poor performance. I've been using linux for almost 3 months now, it's like everything is a battle to get a task done.

share|improve this question
add comment

3 Answers

Since you have a recent machine, you might be using hybrid graphics (nVidia Optimus in this case). If that's the case, you could very well be running on the weaker integrated graphics rather than on your dedicated graphics card, which causes lag.

If this is indeed your problem, you need to install bumblebee which will offer support for hybrid graphics. The procedure is described here: https://wiki.ubuntu.com/Bumblebee#Installation

Once installed, you need to run your game using your dedicated graphics card. This can be done by executing optirun instead of directly invoking the command:

optirun wine yourgame.exe
share|improve this answer
    
From the bit of research I did, it appears bumblebee is meant for laptops. I have no choice but to use my dedicated graphics card, there is no integrated. I am on a desktop. –  Bob Jun 9 '13 at 21:15
add comment

As mentioned before you need to install bumblebee and with command optirun you have to run a game but i suggest to install by this manual http://www.webupd8.org/2013/02/bumblebee-31-released-with-primus.html , because there is used primus which takse shorte way and by that inproves performance.

and in wine they are running crappy because opengl on linux is cutted like hell and even if it shows 4.0 it actualy is about 1.6 in performance. So don't be suprised when windows games which are not native in linux , runs crappy in wine.

share|improve this answer
    
Like I just told the first posted, I am not on a laptop, there is no way that my computer could be using an integrated graphics card instead of my 670 because - I have no other! I'm on a desktop :( –  Bob Jun 9 '13 at 21:16
    
o sry miss readed well. I am not quite sure about desktops, but as far as i remember under additional drivers you should have to be options. At least to my dekstop pc with 9800 gt have. click on software updater then setting and then look in the additional driver. and choose one of them –  rudis Jun 10 '13 at 4:12
add comment

I had the same problem. Some Source games - like latest Portal and CS:GO have the "Multicore rendering" option. Disabling it - will reduce lagging, but game will perform in single core. That's the best option, for now, that I know..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.