Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ASUS UL50Vt with nvidia optimus hybrid graphics (GeForce 210M). I recently installed ubuntu 12.04, and in Details app it was showing me, that I am on Intel video driver. So, I installed bumblebee and after reboot, Details showed "VESA: GT218 Board - 0698a740" As VESA differs from NVIDIA, I uninstalled bumblebee, but bug hasn't gone :(

Now my Xorg.0.log contains:

cat /var/log/Xorg.0.log | grep nvidia
[    12.616] (II) LoadModule: "nvidia"
[    12.634] (WW) Warning, couldn't open module nvidia
[    12.634] (II) UnloadModule: "nvidia"
[    12.634] (II) Unloading nvidia
[    12.634] (EE) Failed to load module "nvidia" (module does not exist, 0)
[    12.634] (==) Matched nvidia as autoconfigured driver 0
[    12.634] (II) LoadModule: "nvidia"
[    12.634] (WW) Warning, couldn't open module nvidia
[    12.634] (II) UnloadModule: "nvidia"
[    12.634] (II) Unloading nvidia
[    12.634] (EE) Failed to load module "nvidia" (module does not exist, 0)

Additional drivers says, that NVIDIA is activated but not currently in use:

jockey-text --list | grep nvidia
kmod:nvidia_current - nvidia_current (Proprietary, Disabled, Not in use)
kmod:nvidia_current_updates - nvidia_current_updates (Proprietary, Enabled, Not in     use)
kmod:nvidia_experimental_304 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_experimental_310 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)

NVIDIA X Server Settings writes on start:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

Suggested by http://askubuntu.com/a/121612/165811

sudo apt-get install linux-headers-`uname -r`
sudo dpkg-reconfigure nvidia-current
sudo nvidia-xconfig
sudo reboot

does not change anything. I'm still on fallback VESA driver. Resolution is 1280x768 instead of 1366x768.

How can I find out why nvidia-current fails to load nvidia module, which, I believe exists:

modprobe -l | grep nvidia
kernel/drivers/video/nvidia/nvidiafb.ko
kernel/drivers/net/ethernet/nvidia/forcedeth.ko
updates/dkms/nvidia_current.ko
updates/dkms/nvidia_current_updates.ko
updates/dkms/nvidia.ko

If it can help, here is my xorg.conf:

cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.88  (buildmeister@swio-display-x86-rhel47-06)  Wed Mar 27 15:32:58 PDT 2013


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Also, how can switch to my on-board Intel graphics, that served me well earlier?

UPDATE

lshw shows me, that my display is UNCLAIMED:

*-display UNCLAIMED
            description: VGA compatible controller
            product: GT218 [GeForce G210M]
            vendor: NVIDIA Corporation
            physical id: 0
            bus info: pci@0000:01:00.0
            version: a2
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress vga_controller bus_master cap_list
            configuration: latency=0
            resources: memory:fd000000-fdffffff memory:e0000000-efffffff memory:fa000000-fbffffff ioport:dc00(size=128) memory:f0000000-f007ffff

It looks like linux does not know about my integrated graphics at all:

lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce G210M] (rev a2)
share|improve this question
add comment

1 Answer 1

I would recommend that you uninstall the nvidia driver and make sure you are running on the intel driver. After this, follow the instructions from the wiki: https://wiki.ubuntu.com/Bumblebee

Please report any specific problems you may encounter when running things exactly as specified in the guide.

Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.