Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying for quite some time to install AMD-drivers to my Ubuntu 13.04 computer. A lot of try-and-fail have been done and a lot of tutorials have been read, and a lot of questions have been asked, but alas, i am still stuck on the same spot.

I dont know if it might be that my machine simply is too old to make use of the drivers available or if it is me that has been downloading the wrong drivers, i never had the same problem on windows thou, but i guess itś not the same.

Anyway, under here i will place my Hardware-information:

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4225/4250]

Not to long ago i made use of NoobLabs tutorial that searches my hardware to see what AMD-drivers i use. " http://www.noobslab.com/search?q=amd&x=0&y=0 " But they did not even find any AMD-Hardware at all, could this be a sign that my computer might be to old?

Previous experience: I have been downloading the drivers i thought would be the corrent ones, however, every time i install "fglrx" Unity stops working and all. Dash also stops working and i have to navigate by using my keyboard.

So if anyone knows how i am to fix this, please help me. I am a gamer and is in dire need to get my graphics working.

share|improve this question
add comment

1 Answer 1

The problem is that the latest fglrx drivers doesn't support 2XXX - 4XXX graphic cards models. Then, the only way I found that may makes the driver working is using fglrx-legacy from this repository: https://launchpad.net/~makson96/+archive/fglrx

The command line steps are these:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

Although, you can install it manually using the official package: http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux.aspx

If you want to install them with the package from AMD (recommended), you can use this guide: What is the correct way to install ATI Catalyst Video Drivers (fglrx)?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.