Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 10.04 (64-bit). I have successfully installed all the dependencies of player and gazebo, then installed player 3.01 and then gazebo 0.9.

Now when I run this :

gazebo worlds/

I get a gazebo interface. Everything is OK up until this point, but when I run this command I see an error:

cd gazebo/player
player gazebo.cfg
player: error while loading shared libraries: cannot open shared object file: No such file or directory

I guess the problem is somewhere in the environmental variables -- can anyone please help me to solve this?

share|improve this question

migrated from Mar 16 '11 at 12:44

This question came from our site for professional and enthusiast programmers.

You should add the directory path containing your library into the LD_PATH variable of your environment.

share|improve this answer
hi greydet!! thnx for the reply, i found that is present in /usr/local/lib64 , now i edited my bash.rc file like this, export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib64 and i get this errorusama@ubuntu:~/gazebo-0.9.0/player$ player gazebo.cfg Registering driver Player v.3.0.1 error : Failed to load plugin libgazeboplugin. error : libtool reports error: file not found error : plugin search path: /home/usama/gazebo-0.9.0/player:.:/usr/local/lib/ error : failed to load plugin: libgazeboplugin error : failed to parse config file gazebo.cfg driver blocks – usama yaseen Mar 16 '11 at 12:37
i am totally new to ubuntu , can u please write the commands which i have to write to edit my bash.rc – usama yaseen Mar 16 '11 at 12:38
Once you have added the export command from your bashrc file, did you think to re-source it in your env or just close your current terminal window and reopening a new one for the bashrc to be reloaded? – greydet Mar 16 '11 at 12:46
i don't understand by re-source it in your env? , i edited my bashrc file and then save it and then open a new terminal and try the commands , what else one has to do after editing the bashrc file ? – user12484 Mar 19 '11 at 16:51
If you reopened a new terminal it is ok then, nothing much should be done. Are you sure your file is directly located within /home/usama/gazebo-0.9.0/player directory? – greydet Mar 19 '11 at 18:44

Using this url, I have come up with these instructions:

gksudo gedit /etc/bash.bashrc

and then add the following to the .bashrc file:

export PATH=$PATH:"/usr/local/lib64"
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"/usr/local/lib":"/usr/local/lib64"
export PLAYERPATH="/usr/local/lib":"/usr/local/lib64"
export STAGEPATH="/usr/local/lib":"/usr/local/lib64"

Save it then run:

source /etc/bash.bashrc
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.