Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have internet via ethernet cable plugged in directly into my desktop machine; windows and ubuntu on the same machine.

The problem is that after loggin in internet is working (though the speed is less than on Windows) for about 10 mins, after which connection disappears: cannot ping anything, nslookup is not responding too. Then after about 10 mins connection is back.


I'm not much familiar with Ubuntu, sorry if some info is missing. I have

Ubuntu version: 10.04.4 LTS
Codename: lucid

(for some reason I have to stay on 10.04 and cannot upgrade to a newer version now)

Network interfaces:

~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

Ethernet controller:

~$lspci -v
...
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
        Subsystem: ASUSTeK Computer Inc. Device 8432
        Flags: bus master, fast devsel, latency 0, IRQ 31
        I/O ports at d000 [size=256]
        Memory at f2104000 (64-bit, prefetchable) [size=4K]
        Memory at f2100000 (64-bit, prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: r8169
        Kernel modules: r8169
...
share|improve this question
    
Currently I'm using my friend's computer and it has the same problem. Ubuntu 13.04 32bit –  ilhan Sep 22 '13 at 21:48
    
Paste /etc/udev/rules.d/70-persistent-net.rules and /etc/NetworkManager/NetworkManager.conf contents. –  Terry Wang Sep 22 '13 at 23:36
    
Anything in logs after the disconnect? –  int_ua Sep 23 '13 at 1:26
    
@ilhan I believe you should have asked your own question instead placing a bounty over this one. Hardware problems are preferred in the basis of 1 question per person per combination of hardware and kernel. –  Braiam Sep 23 '13 at 2:35

2 Answers 2

up vote 3 down vote accepted
+50

I solved this already by changing kernel driver version from r8169 to r8168. http://www.foxhop.net/realtek-dropping-packets-on-linux-ubuntu-and-fedora

share|improve this answer
    
@ilhan, please try it and write if it helps –  xaxa Sep 23 '13 at 7:43
  1. Update your system, esp the Kernel. Reboot and check now.
  2. If it's still not solved, try getting a more stable driver like the R8168B:

    • Download the R8168B linux driver:

      • older version: wget http://www.foxhop.net/attachment/r8168-8.023.00.tar.bz2 tar vjxf r8168-8.023.00.tar.bz2

      • or get the latest version from Realtek.

    • Check whether the built-in driver, r8169.ko (or r8169.o for kernel 2.4.x), is installed: lsmod | grep r8169

    • R8169 seems installed if the lsmod command returns output, so remove r8169 with: sudo rmmod r8169

    • Install the Realtec r8168b nic driver: cd r8168-8.023.00 sudo ./autorun.sh

    • Prevent the r8169 driver from loading again: echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf

    • You may now verify that r8168b has been installed and loaded by running: lsmod | grep r8168

    • To avoid R8169 driver returning after reboots, clean the cache using the following command: update-initramfs -u

Source: Realtek NIC driver r8169 dropping packets on linux ubuntu and fedora

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.