Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

im having issues with my HD 5770 running on the proprietary driver that i get from "system/administration/additional drivers"

im using Ubuntu 10.10 and a DVI to VGA converter on a CRT screen .

  1. so can i use only Xorg to run my GPU with out installing any drivers ?

  2. if yes how to make a fully working Xorg file ?

share|improve this question

I m using same card too. There is no problem with 11.04 and 11.10.

Only these commands and reboot:

sudo apt-get install fglrx
sudo reboot

After restarting, please type to terminal:

env LC_ALL=C amdxdg-su -c amdcccle

It will open Catalyst Control Center window:

share|improve this answer

If you uninstall previous driver then Ubuntu will use the open source driver for your card(radeon driver).

If you use sudo rm /etc/X11/xorg.conf and reboot it probably will work. Change preferred resolution in System -> Preferences -> Monitor.

share|improve this answer
how do i put in the screen res and refresh rates – Hossam Riyad Mar 16 '11 at 13:40
You should be able to change that in Monitor settings. If not you will have to change that manually in /etc/X11/xorg.conf. If you change it manually you will have to restart X with following combination: CTRL + ALT + Print Scrn + K. – mount.cifs Mar 16 '11 at 14:02
can u tell me how to change it ? – Hossam Riyad Mar 17 '11 at 9:05

I'm using a Radeon HD5850, so it isn't exactly the same card, but your experiences should be similar.

In older versions of Ubuntu, the open drivers were not very good and you almost had to use the proprietary drivers. In 11.04, there were great improvements to the open drivers, but there were still a few issues with Unity, although they were minor. In 11.10, there is no doubt that I prefer the open drivers. They're faster, more stable and makes things easier in general.

In other words, unless you have very good reasons not to, I would strongly encourage you to check out the newest versions of Ubuntu and see if the problems just go away.

share|improve this answer

to ask your question a single command is enough

sudo aticonfig --initial

with this your xorg.conf is properly written, it's ok and fully working.

But, if i can suggest you something better than the driver you are actually using, install the proprietary driver from the official website ( first remove the one you have installed from the official repository and every fglrx-related packages ) maybe you can follow the instructions at this page .

There is nothing wrong with the fglrx package from the official repository but it's really outdated and sometimes the latest driver from the official website works better.

I have an XFX XXX 5770 1Gb and everything works like a charm with the latest driver.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.