Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I just down-rev'd ubuntu from 13.04 back to 12.04 LTS desktop 64 (Precise). I am using Unity. I just reformatted the Ubuntu partition, but kept my home directory intact, and everything seemed to reconnect just fine. No data was lost. However, I found that I cannot seem to change my preferences. So I cannot seem to change my desktop background, no matter how many ways I try--Ubuntu Tweak, Gnome Tweak, system settings. I also cannot change the system GTK+ theme, though apparently I am able to change the windows border theme. Further, I cannot seem to change my Nautilus preferences--so I cannot seem the make the default view a list view, and I cannot make the "single-click" behavior the default. I even went into the nautilus org.gnome.nautilus settings to manually change things, but no luck.

I thought it was a permissions issue, so I did a chown on the home folder and on the .gvfs folder. Still no luck. So somewhere there seems to be a permission that I am not catching. Does anyone have any suggestions? Thanks.

share|improve this question
add comment

3 Answers 3

Install Ubuntu Tweak 0.8.5 in Ubuntu 12.04

To get started, press Ctrl – Alt – T on your keyboard to open the terminal. When it opens, run the commands below to add its PPA.

sudo add-apt-repository ppa:tualatrix/ppa

Finally, run the commands below to update your system as well as install Ubuntu Tweak.

sudo apt-get update && sudo apt-get install ubuntu-tweak

Ubuntu Tweak 0.8.0

Using This software you can change any theme, preferences and so on.

Find More stuff about Ubuntu here: Noobs lab

share|improve this answer
    
Hey @Reaper. Thanks for the suggestion. I actually tried using Ubuntu-Tweak and Gnome Tweak as well. For some reason, neither of these are working. Not sure what the reason for that is. –  krishnab Jun 9 '13 at 9:04
add comment

I found that reinstalling ubuntu and reformatting the /home directory worked. I think that trying to leave the original home directory intact leads to some permissions issues that are hard to detect. Sorry for a less than satisfactory solution, but it worked.

share|improve this answer
add comment
$ chmod -R 775 ~/

you have to apply permission 775 to /home folder (:

share|improve this answer
    
In my opinion, I think it's not good practice to set it to 777, because you're basically giving everyone access to your /home folder, which really contradicts the purpose of having a home folder for each user. You could use 775 or even 770. –  Alaa Jun 21 '13 at 6:04
    
I think it's not good practice too. Sorry :( –  tineo Jun 24 '13 at 16:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.