Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I posted this to the ubuntuforums, but got no answer there, so I'm trying here:

While going over the keyboard shortcuts (System> Preferences> Keyboard Shortcuts), I accidentally assigned the delete key to a shortcut. I backspaced and cancelled, but next time I pressed "delete" the key didn't work. I tried creating a new shortcut called Delete and this got me a weird pop up saying "Error while trying to run (Delete) which is linked to the key (Delete)". I removed the shortcut, but it's still assigned.

I deleted the custom shortcut, but to no avail. Any ideas? this drives me bonkers, as it's such a used key

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

Another way is to go to the gconf-editor and edit the binding in /apps/metacity/global_keybindings/ or /desktop/gnome/keybindings keys.

share|improve this answer
add comment

Remove an unwanted keyboard shortcut

Open the dialogue in System -> Preferences -> Keyboard Shortcuts and select the entry you need to delete:

enter image description here

Once the entry is selected you can either enter a new shortcut, or in case you want to disable a shortcut for this action press Backspace (not Delete as this is a key that could be assigned as shortcut as well). You can close the window then.

Please reboot your system for disabling a shortcut to take effect

share|improve this answer
    
That is exactly not what I needed, since this is what I done and it didn't work –  Erez Schatz Mar 23 '11 at 9:23
    
Of course I did test this procedure! This confirmed your findings that deleting the shortcut has no immediate effect. However on my system after a reboot everything was reset as expected. Glad that @arrange's solution worked for you. –  Takkat Mar 23 '11 at 10:08
    
This worked for me, much simpler than gconf. –  jco Jun 9 at 15:12
add comment

I'm not sure about this but after reading the man page for dpkg it makes sense. If you run this command it should return the keyboard short cuts to there default.

sudo dpkg -configure -a

Hope this solves your problem

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.