Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Ubuntu 13.04 and when I try to run Minecraft, after a few minutes the whole system freezes and I have to hold down the power button on my laptop and reboot as the laptop just completely stops responding.

I have tried with OpenJDK 6 & 7 and it crashes with both. I have tried removing mods, but it still happens. Is there any way that I can stop this from happening?

I am using the following graphics card:

00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Sumo [Radeon HD 6380G]

I tried deleting the game data, and that did nothing. CtrlAltF1 also did nothing after the crash, but for some reason my laptop refused to turn back on for a bit afterwards when I tried that command.

share|improve this question
    
Post the output off lspci | grep VGA –  leszakk Jun 8 '13 at 19:33
    
Could you please paste the results of sudo lshw in the Ubuntu Pastebin (paste.ubuntu.com), and paste the resulting link here? –  haneefmubarak Jun 8 '13 at 19:33
    
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Sumo [Radeon HD 6380G] –  Adam Griggs Jun 8 '13 at 19:37
    
paste.ubuntu.com/5746101 –  Adam Griggs Jun 8 '13 at 19:46
    
Try deleting the game data in ./.mincraft/ –  leszakk Jun 8 '13 at 19:46

1 Answer 1

You want to install proprietary graphics drivers if you haven't already. (You didn't mention that you did, so I'm just assuming you have not yet.) Open the Software Sources app, and click the "Additional Drivers" tab. You can install fglrx drivers from there, which will allow you to take full advantage of the card's capabilities and probably stop the crashes.

share|improve this answer
    
I have installed the proprietary graphics driver, and that has fixed the problem with the crashes, but I am now getting a little box on the bottom right of my screen which has the AMD logo at the top, and then says 'Unsupported Hardware' underneath. Is this going to be a problem or is it ok? –  Adam Griggs Jun 9 '13 at 12:01
    
Ok, try selecting the fglrx-updates driver if it appears, instead, or install the fglrx-updates package. –  Richard Jun 10 '13 at 18:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.