Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am over 18 hours deep on this challenge. I got to this point and am stuck. very stuck. Maybe you can figure it out?

Ubuntu Version 12.04 LTS with all the updates installed.

Problem: The default settings in "etc/X11/xorg.conf" that are generated by the "nvidia-xconfig" tool, do not allow the NVIDIA x server to connect to the driver in my "System Settings > Additional Driver window". (that's how I understand it. Lots of information below).

Symptoms of Problem

  1. "System Settings > Additional Driver" window has drivers, but the nvidia x server cannot connect/utilize any of the 4 drivers. the drivers are activated, but not in use. enter image description here

  2. When I go to "System Tools > Administration > NVIDIA x server settings" I get an error that basically tells me to create a default file to initialize the NVIDIA X server (screen shot below). enter image description here

  3. This is the messages the terminal gives after running a "sudo nvidia-xconfig" command for the first time. It seems that the generated file by the tool i just ran is generating a bad/unusable file:enter image description here

  4. If I run the "sudo nvidia-xconfig" command again, I wont get an error the second time. However when I reboot, the default file that is generated (etc/X11/xorg.conf) simply puts the screen resolution at 800 x 600 (or something big like that).

  5. When I try to go to NVIDIA x server settings I am greeted with the same screen as the screen shot as in symptom 2 (no option to change the resolution). If I try to go to "system settings > display" there are no other resolutions to choose from. At this point I must delete the newly minted "xorg.conf" and reinstate the original in its place.

  6. Here are the contents of the "xorg.conf" that is generated first (the one missing required information):

     # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    
     # nvidia-xconfig:  version 304.88  (buildmeister@swio-display-x86-rhel47-06)  Wed Mar 27 15:32:58 PDT 2013
    
       Section "ServerLayout"
           Identifier     "Layout0"
           Screen      0  "Screen0"
           InputDevice    "Keyboard0" "CoreKeyboard"
           InputDevice    "Mouse0" "CorePointer"
       EndSection
    
       Section "Files"
       EndSection
    
       Section "InputDevice"
            # generated from default
            Identifier     "Mouse0"
            Driver         "mouse"
            Option         "Protocol" "auto"
            Option         "Device" "/dev/psaux"
            Option         "Emulate3Buttons" "no"
            Option         "ZAxisMapping" "4 5"
        EndSection
    
        Section "InputDevice"
            # generated from default
            Identifier     "Keyboard0"
            Driver         "kbd"
        EndSection
    
        Section "Monitor"
            Identifier     "Monitor0"
            VendorName     "Unknown"
            ModelName      "Unknown"
            HorizSync       28.0 - 33.0
            VertRefresh     43.0 - 72.0
            Option         "DPMS"
        EndSection
    
        Section "Device"
            Identifier     "Device0"
            Driver         "nvidia"
            VendorName     "NVIDIA Corporation"
        EndSection
    
        Section "Screen"
            Identifier     "Screen0"
            Device         "Device0"
            Monitor        "Monitor0"
            DefaultDepth    24
            SubSection     "Display"
                Depth       24
        EndSubSection
     EndSection
    

Hardware: I ran the "lspci|grep VGA". There results are:

     00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
     01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [Quadro 1000M] (rev a1)

More Hardware info: Ram: 16GB CPU: Intel Core i7-2720QM @2.2GHz * 8 Other: 64 bit.

This is a triple boot computer and not a VM.

Attempts With Not Success on My End:

1) Tried to append the "xorg.conf" with what I perceive is missing information and obviously it didn't fly.

2) All the other stuff I tried got me to this point.

3) See if this link is helpful to you (I barely get it, but i get enough knowing that a smarter person might find this useful):

http://manpages.ubuntu.com/manpages/lucid/man1/nvidia-xconfig.1.html

4) I am completely new to Linux (40 hours over past week), but not to programming. However I am very serious about changing over to Linux. When you respond (I hope someone responds...) please respond in a way that a person new to Linux can understand.

5) By the way, the reason I am in this mess is because I MUST have a second monitor running from my laptop, and "System Settings > Display" doesn't recognize my second display. I know it is possible to make the second display work in my system, because when I boot from the install CD, I perform work on the native laptop monitor, but the second monitor shows a purple screen with Ubuntu in the middle, so I know the VGA port is sending a signal out. If this is too much for you to tackle please suggest an alternative method to get a second display. I don't want to go to windows but I cannot have a single display. I am really fudged here. I hope some smart person can help.

Thanks in advance.

Mike.

**********************EDIT #1**********************

More Details About Graphics Card

I was asked "which brand of nvidia-card do you have exactly?" Here is what I did to provide more info (maybe relevant, maybe not, but here is everything):

1) Took my Lenovo W520 right apart to see if there is an identifier on the actual card. However I realized that if I get deep enough to take a look, the laptop "won't like it". so I put it back together. Figuring out the card this way is not an option for me right now.enter image description here

2) (My computer is triple boot) I logged into Win7 and ran 'dxdiag' command. here is the screen shot:enter image description here

3) I tried to look on the lenovo website for more details... but no luck. I took a look at my receipts and here is info form receipt:

System Unit: W520 NVIDIA Quadro 1000M 2GB

4) In win7 I went to the NVIDIA website and used the option to have my card 'scanned' by a Java applet to determine the latest update for my card. I tried the same with Ubuntu but I can't get the applet to run. Here is the recommended driver from from the NVIDIA Applet for my card for Win7 (I hope this shines some light on the specifics of the card):

Quadro/NVS/Tesla/GRID Desktop Driver Release R319

Version: 320.00 WHQL

Release Date: 3.5.2013

5) Also I went on the NVIDIA driver search and looked through every possible combination of product type + product series + product to find all the combinations that yield a 1000M card. My card is:

Product Type: Quadro

Product Series: Quadro Series (Notebooks)

Product: 1000M

***********************EDIT #2*******************

Additional Symptoms

Another question that generated more symptoms I previously didn't mention was:

"After generating xorg.conf by nvidia-xconfig, go to additional drivers, do you see nvidia-304?"

1) I took a screen shot of the "additional drivers" right after generating xorg.conf by nvidia-xconfig. Here it is: enter image description here

2) Then I did a reboot. Now Ubuntu is 600 x 800 resolution. When I logged in after the computer came up I got an error (which I always get after generating xorg.conf by nvidia-xconfig and rebooting) enter image description here

3) To finally answer the question - No. There is no "NVIDIA-304" driver. Screen shot of additional drivers after generating xorg.conf by nvidia-xconfig and rebooting : enter image description here

At this point I revert to the original xorg.conf and delete the xorg.conf generated by Nvidia.

share|improve this question
    
After generating xorg.conf by nvidia-xconfig, go to additional drivers, do you see nvidia-304? –  thefourtheye Jun 8 '13 at 18:01
    
which brand of nvidia-card do you have exactly ? Geforce with optimus CUDA ? –  dschinn1001 Jun 8 '13 at 19:01
    
@dschinn1001 Hello, I answered your question by adding an "edit #1" section at the end of the original question post. There you can see all the information I could get to answer your question. Please take a look. If I can do more investigation, to get you more info that you may need... by all means tell me what else I can do, and I will do it. Thanks for looking at my question, I hope we can figure it out. Have a nice day! I just realized you were the one who provided the only solution. I will try that before tommorow night and I will post all the results of that. –  Mike Jun 9 '13 at 15:14
    
yes see my answer. your card-type includes support for optimus with CUDA (have seen technical description in the web). this means you might try the package I named below. Because this package is just new from May and more actual than nvidia-packages, which are encluded in Debian resp. Ubuntu - and - you have set your display Nr. 2 to 32 Bit under Windows ? –  dschinn1001 Jun 9 '13 at 15:21
    
@dschinn1001 I already downloaded the driver you recommended and I will perform your procedure before tomorrow night. As for the 32 bit display... I guess so. My displays work and I don't game, so even if it seems underused its good enough for me. And thanks for all the suggestions and information. Thank you. –  Mike Jun 9 '13 at 15:32

2 Answers 2

interesting graphics card. it has the same architecture like mine GT 540 M and is designed too with optimus resp. CUDA

I would download this driver package at http://nvidia.com (it is working best here - because of supporting optimus CUDA).

NIVIDIA_CUDA_SDK_1.1_Beta_Linux.run

Then there is this exotic link of mine contribution how to install it:

nvidia-frickle with hybrid chipset is now over finally?

I had same problem with nvidia-xconfig too, before this solution of mine.

This contribution was only rated with -4 because it is written as blog and not as question.

share|improve this answer

I kept at this problem for a very long time (minimum 150 hours in effort over 14 months). Everything I tried didn't fly; and I tried so many things.

I even hired a programmer to complete this process because it looks so promising: http://sagark.org/optimal-ubuntu-graphics-setup-for-thinkpads/ However, we were not able to do it successfully - maybe you will have better luck.

However I WAS able to make the second monitor work on my Lenovo W520 laptop with the NVIDIA Quadro 1000m card. all I did was install 14.04 and I finally got my second monitor.

Nothing I tried in 12.04 or 12.10 or 13.10 worked for me. The closest was 13.10 with a refresh rate of once every 5 seconds on the second monitor. Avoid this huge headache and just install 14.04 - as it works out of the box!!!

My advice is if you have a lenovo w520 with Quadro 1000m, just install 14.04 and everything works.

If for some reason you must have 12.04, then don't let my experience discourage you, just keep in mind I am completely new to Linux. There are lots of people with W520's and 12.04 with multiple screens - it's just that I was not able to replicate their feats.

Good Luck

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.