Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi I have a gps receiver bu-353 with usb interface i want to know how can i use it under ubuntu I ran the following command

gpsd -n -N -D 2 /dev/ttyUSB0 I got the output as:

gpsd: launching (Version 2.94)
gpsd: listening on port gpsd
gpsd: running with effective group ID 1000
gpsd: running with effective user ID 1000
gpsd: opening GPS data source type 3 at '/dev/ttyUSB0'
gpsd: speed 38400, 8N1
gpsd: Garmin: garmin_gps Linux USB module not active.
gpsd: speed 9600, 8O1
gpsd: speed 38400, 8N1
gpsd: gpsd_activate(): opened GPS (fd 6)
gpsd: speed 4800, 8N1
gpsd: NTPD ntpd_link_activate: 0
gpsd: /dev/ttyUSB0 identified as type SiRF binary (2.687608 sec @ 4800bps)
gpsd: detaching (sub 1, fd 8) in detach_client
gpsd: detaching (sub 1, fd 8) in detach_client

after this i started tangoGPS, which said no gps and no gpsd found

share|improve this question
Parimal, was the answer below helpful for you? Please mark it accepted if so, otherwise provide more information on how you tried to solve the problem and failed. Thank you. – Mirzhan Irkegulov Feb 25 '12 at 14:58

bu-353 is known to work with gpsd.

1) Try the -b flag (for example, gpsd -b /dev/ttyUSB0)

2) Open a separate terminal window and run gpsmon (included in the 'gpsd-clients' package) to check gpsd output. Restart gpsmon each time you restart gpsd.

Could tango be starting too soon? The dongle requires a few seconds to sort out the signals, identify satellites, and calculate a fix, udev requires a few seconds to start gpsd, which in turn requires a few seconds to probe the dongle (which may not be ready yet) and begin broadcasting useful information when the data stream finally begins. gpsmon can help diagnose that problem, too.

3) If there's no gpsd output, then do a more detailed check. Do the following steps in order to test the dongle, the kernel module, the mount, the device node, and gpsd:

  • Unplug the USB dongle and kill gpsd (sudo pkill gpsd). Wait 10 seconds for /dev/ttyUSB0 to be freed.
  • Plug the USB dongle back in and wait 10 seconds.
  • Check dmesg | tail -n 5 to verify the dongle was really mounted to /dev/ttyUSB0. If it doesn't mount, then you're missing a kernel module (from your description, that's unlikely). Sometimes it gets mounted to /dev/ttyUSB1 if 0 isn't free!
  • See if udev recognized the dongle and started gpsd (ps -e | grep gpsd). If not, then you have a udev rules issue, and you must start gpsd manually with gpsd /dev/ttyUSB0
  • Once gpsd is running, check for dongle output (dongle output = gpsd input). Try cat /dev/ttyUSB0 (stop it with CTRL+c). If that fails, then try resetting the baud rate to 4800:

    pkill gpsd
    stty 4800 > /dev/ttyUSB0
    gpsd -b /dev/ttyUSB0
    cat /dev/ttyUSB0     # CTRL+c to stop
  • If you have have good dongle output (=gpsd input), open a second terminal window and try either gpsmon or cgps to test gpsd output.
  • Finally, now that you have good dongle output and good gpsd output, try tangoGPS.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.