Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Unity 2d's workspace animation runs very slowly on my old graphics card. How do you disable them?

share|improve this question
add comment

5 Answers

up vote 4 down vote accepted

You can set transitionDuration = 0 in the file /usr/share/unity-2d/spreed/utils.js.

share|improve this answer
add comment

There is no simple way to disable the workspace switcher. It requires changes in the code of Unity 2D.

share|improve this answer
    
And for the hard ways, see Igor's answer. –  phq Aug 13 '12 at 17:16
add comment

I'm running Ubuntu Precise, and the following did it for me:

  • Run "CompizConfig Settings Manager" (not sure if it's installed by default)
  • Select "Desktop Wall" under Desktop
  • Disable "Show Viewport Switcher Preview"
  • Select the "Viewport Switching" tab
  • Set "Wall Sliding Duration" to zero

Now when switching desktops via the keyboard, I don't get any animations.

share|improve this answer
1  
The question is about Unity-2d, Compiz settings does not change Unity-2d behaviour. –  phq Aug 13 '12 at 17:12
add comment

Install dconf-tools Install dconf-tools (should be available in Maverick, it definitely is in Natty. I'm on Lucid so I can't check). Open dconf-editor and search for unity. There are several tunables, though I'm not sure the workspace animation is one of them.

share|improve this answer
1  
... no such option ... –  Evan Mar 16 '11 at 18:57
add comment

Probably the best solution is to log in with the "Classic Gnome Desktop" (drop-down menu is at the bottom of the GDM Greeter after selecting your username). This will avoid Unity completely.

share|improve this answer
1  
"Classic gnome desktop" keeps crashing. And anyway, unity 2d is much fancier. –  Evan Mar 16 '11 at 7:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.