Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble enabling the directory listing on apache. I did it a few weeks ago but had to reinstall cause my Wubi ran out of space, and now I can't get it to work and it's driving me crazy.

I have a folder /home/joon/Dropbox/Projects/apache, which I want to set as the root for my apache. Here's the first lines of the 'default' file in the sites-available folder:

<VirtualHost *:8888>
ServerAdmin webmaster@localhost

DocumentRoot /home/joon/Dropbox/Projects/apache
<Directory /home/joon/Dropbox/Projects/apache>
    Options +Indexes FollowSymLinks
    AllowOverride None

The rest is unchanged. Ports.conf is set to Listen 8888. I thought the +Indexes should do it, but I must have overlooked something.

I get a 403, forbidden. "You don't have permission to access / on this server." If I input the url of an image, http://127.0.0.1:8888/joon/bin/1chart.png, it displays, but no directory listing.

Please help.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

The '+' symbol before 'Indexes' is not needed.

Options Indexes FollowSymLinks

Will suffice.

share|improve this answer
    
what the... I'm so sure I tried that first. Now I feel stupid. Anyway, it works, thanks a lot. –  joon Mar 16 '11 at 4:37
    
Okay, I get the directory listing, but when I click one of the directories that has an index.php or index.html, Chromium downloads that page instead of serving it. If I navigate to the index.php page it displays however. Any ideas? –  joon Mar 16 '11 at 4:40
    
Is that the same result for all browser or just for chromium?. –  aneeshep Mar 16 '11 at 4:58
    
it should be the same result across all internet browsers. –  Thomas W. Mar 16 '11 at 7:58
    
it's acting super weird. From my virtualbox I can access the apache server and it displays as expected, but locally I get downloads instead of displayed pages. I'll open up a new question if the issue persists... –  joon Mar 16 '11 at 17:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.