Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I installed Lubuntu, computer boots directly to windows 7 and its not showing the boot menu. Now I have access to windows only. During the installation I choose to install it on different partition and the boot file location I set it to the same partition I installed Lubuntu on and its not the partition that windows is installed in. windows on partition ==> sda1 and windows boot loader as well is here. lubuntu and its boot loader ==> sda7.

what shall I do now ? re-install lubuntu?

share|improve this question
    
can you add the output of sudo fdisk -l. Boot from the Lubuntu CD, and then get that output. –  Mitch Jun 8 '13 at 11:00
    
I can not boot into lubuntu it goes directly to windows as if lubuntu was not there –  za3bolla Jun 8 '13 at 11:01
    
I am unable to take screen shot of it the boot device is set to sda1 –  za3bolla Jun 8 '13 at 11:47

3 Answers 3

Try this.

You need to Re-install grub to the MBR booting from the liveCD /dev/sdaX, where X is the root partition.

sudo mount /dev/sdaX /mnt
sudo grub-install --root-directory=/mnt /dev/sdXX
sudo umount /mnt

And then reboot the machine, grub menu should come up now.

Note: windows 7 loader is listed in grub.cfg so re-installing grub will also give access to windows.

Based on your last comment, I would try to get a backup of all important files, just in case, and then re-install Lubuntu.

Source: Grub 2 Basics

share|improve this answer
    
when I entered the grub install command it said this : Path `/mnt/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting. –  za3bolla Jun 8 '13 at 12:28
    
when I reinstall it where should I specify the boot file location ?? –  za3bolla Jun 8 '13 at 13:12
    
I previously specified it to sda7 shall I just leave it sda –  za3bolla Jun 8 '13 at 13:49

You'll need to install Grub Bootloader to the entire disk to be able to select which operating system you want to use at boot, not just to the Lubuntu partition. You can follow these instructions to do that with a Ubuntu or Lubuntu Live CD or USB.

share|improve this answer
    
mount: mount point /mnt/dev does not exist I get this when I try the 2nd command –  za3bolla Jun 8 '13 at 11:38
    
the first command did not work either so I had to mount them myself using "Disks" application –  za3bolla Jun 8 '13 at 11:39

I re-installed the whole thing .. and did not mess with the boot loader location option and everything is working fine.

Thanks guys in advance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.