Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've looked around for answers to this, but nothing I've found has been relevant, which seems a little weird but there you go. All I'd like to do is drive a second monitor via HDMI from a laptop. From Windows 7 on this laptop that works fine, of course; it's actually surprisingly nice. Thus I know the hardware is OK.

From another laptop I've got, one with an NVidia card, the NVidia settings app seems to do the trick (though it's clunky). However, this laptop I'm using has an Intel GPU, and I can't find any information about how to get it to recognize that a second display is available. Is it even possible to do this dynamically, or do I need to statically alter my "xorg.conf" to make the second screen available?

edit — sorry I should have noted that I run xfce.

share|improve this question
    
Have you tried connecting the monitor and going to System>Preferences>Monitors? Do both show up? If not, have you tried leaving the monitor plugged in and restarting, then going to the settings? Have you checked the bios? Sorry to barrage you with questions, but that's everything I can think of that could think of being helpful. –  aperson Aug 25 '10 at 6:44
    
There is no such thing as "System > Preferences > Monitors" in the xfce desktop. –  Pointy Aug 25 '10 at 14:10

2 Answers 2

up vote 1 down vote accepted

I ended up logging a bug, because it seems that the Intel driver simply doesn't detect the HDMI interface at all. Maybe it'll get fixed when they get the dual-chip driver done.

share|improve this answer

Open System/Preferences/Monitors and click 'Detect'. This is the standard way and should "Just Work". I assume you tried this already and it didn't just work.

Next, I'd try doing it from the command line: xrandr --auto

If that didn't work, time to debug. Run xrandr by itself and examine the output. It should show you that there is an HDMI output, and should indicate if you have a monitor connected to it, and should show what resolutions it supports.

If it all looks okay, you can force the monitor's setup using the xrandr command line tool. See man xrandr or the various examples at http://wiki.ubuntu.com/X/Config.

If it doesn't look ok, well there's a whole host of different problems that could have resulted in that. http://wiki.ubuntu.com/X/ collects a lot of wisdom for troubleshooting these sorts of problems. For example, if your monitor is actually a TV, there's some workarounds for that.

share|improve this answer
    
Thanks - sorry I didn't say that I run xfce, and there's no such thing as "System > Preferences > Monitors." However, running "gnome-display-properties" and clicking "Detect" does nothing. –  Pointy Aug 25 '10 at 14:11
    
Running xrandr shows just screen 0 (the laptop screen). –  Pointy Aug 25 '10 at 14:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.