Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried everything and literally followed this tutorial: http://www.dedoimedo.com/computers/ubuntu-quetzal-nvidia.html 10 times from top to bottom and I still can't get my nvidia drivers installed. I am running ubuntu 13.04. It should be noted that when I type:

lsmod|grep nvidia

I get an output of:

nvidia       11309139 0

I can still see the screen, as stated in my other question, and I can still interact with folders on my desktop and open terminal. My screen looks like this: enter image description here

That is all I see, and I'm thrown constant "Ubuntu has experienced a severe problem" and then I am asked to send logs from nvidia. So, I'm guessing it is installed.

share|improve this question
1  
What is the output of lshw -c video | grep -in configuration? –  thefourtheye Jun 8 '13 at 14:42
    
11 Configuration: driver=nvidia latency=0 23 Configuration: driver=i915 latence=0 –  ReallyGoodPie Jun 9 '13 at 3:26
1  
Open Software & Updates and Select Additional Drivers tab. Please post a screenprint of that window. –  thefourtheye Jun 9 '13 at 4:22
add comment

1 Answer

up vote 0 down vote accepted

Ok, so I managed to get it to work perfectly and here is the following process I took to install it:

Go to the Nvidia site and download the correct java for Linux (take not of its name and location)

After downloading, press Ctrl + alt + F1 and you will be brought to a terminal like window

Login and then cd to the location of your Nvidia file

Type the following commands:

Close the X Server: sudo service lightdm stop

chmod the Nvidia File: chmod +x NVIDIA-Linux-x86_64-xxx.xx.run

Run the Nvidia File: sudo sh NVIDIA-Linux-x86_64-xxx.xx.run

Note: You may get an error telling you that Nouveau needs to be disabled. Just follow the prompts and it will offer an option to disable it automatically. After this type sudo shutdown -r now to restart the computer. Follow the above steps again and it should now be installed.

However

Your resolution will now probably be completely tiny due to it now being in power save mode. To fix this, perform the following:

cd to xorg.conf file: cd /etc/X11

Editing the xorg.conf file sudo gedit xorg.conf

You should now have something open with something like this:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

back up this file and then you will now need to edit it

Get you monitor files

sudo apt-get install hwinfo
sudo hwinfo --monitor

Take not of the attributes that show and then enter them into your xorg.conf file. You want to remoce the power saving option "DPMS" and update the HorizSync and VertRefresh to your monitors settings.

My Monitor section looked like the following:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 72.0
    VertRefresh     43.0 - 60.0
EndSection

Such a pain just to install a Nvidia driver considering Windows just uses a simple installation program and its done.

share|improve this answer
    
Have you tried running sudo nvidia-xconfig instead of editing the xorg.conf file yourself? –  GermanK Jun 11 '13 at 14:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.