Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted syntax highlighting in vim. I read in some forum that I should do:

sudo apt-get install vim

I guess there were a lot of dependencies, so it took a while. I typed "YES" a few times without really reading the prompts.

My computer restarted and now my mouse & internet don't work. I suspect something got messed up in gnome.

I should mention that things were working perfectly before I ran the command to update vim (namely, my mouse and internet were working).

How to fix?

I believe I'm using 8.04.

*EDIT: More Info *

cat /etc/issue = Ubuntu 8.04.4 LTS \n \l

/var/log/messages is empty.

cat /var/log/Xorg.0.log | grep EE =

(EE) module ABI major version (7) doesn't match the server's version (2)

(EE) Failed to load module "mouse" (module requirement mismatch, 0)

(EE) fglrx(0): atiddxDriScreenInit failed, GPS not initialized.

(EE) No input driver matching 'mouse'

EDIT: Attempt 1

I tried the following (as mentioned here):

$ sudo update-rc.d -f gdm remove #get rid of the old boot symlinks

$ sudo update-rc.d gdm defaults 25 #add the new ones with a higher priority

I restarted and got an IRQ 19 Nobody Cared error.

share|improve this question
1  
This question is a little vague on information. in a console, cat /etc/issue to find out what version of ubuntu you are running. Have you looked into your /var/log/messages and /var/log/Xorg.0.log for any panic, error, debug messages that would be of use? It may simply be that your XOrg config was over-written by a package. You can try logging in and running –  lazyPower Mar 16 '11 at 0:35
    
This looks interesting. How do I fix an over-written XOrg config? Your comment was cut-off –  dsg Mar 16 '11 at 0:47
    
1  
I restarted and got an IRQ 19 Nobody Cared error. #epic –  lazyPower Mar 16 '11 at 1:06

1 Answer 1

up vote 3 down vote accepted

From what I have gleaned from google, it appears that your update was 'partial' and that some of your XOrg modules did not get upgraded along with your X binaries that were updated. Try re-running a full system update.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade (if sudo apt-get upgrade does not solve the issue)

this time, please take your time, examine the prompts that its asking you.

If this fails to resolve the situation, I'm not sure that anything short of:

  1. ripping apart your install package by package to find the culprit, or
  2. doing a full reinstall, would solve your issue.

[offtopic] When it comes to X failing I'm just happy we arent in the 90's when XFree86 ruled the X user sphere. That was a dependency nightmare. [/offtopic]

share|improve this answer
    
I don't have the patience to resolve these issues. I will just use this as an opportunity to upgrade to ubuntu 10.10 and reinstall everything. There are no bugs in that version, correct? ;) –  dsg Mar 16 '11 at 1:13
1  
I wouldn't say no bugs, but its running VERY stable for me. –  lazyPower Mar 16 '11 at 1:16
    
Upgrading is the right answer. The install was ~30 mins and now my vim does syntax highlighting. –  dsg Mar 16 '11 at 3:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.