Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

in my Lubuntu 13.04 (with Gnome Shell 3.8), Flash videos won't go to full screen in certain Flash players (i.e. on certain sites). - Actually in most players, that means it doesn't work at all. Upon left-click on the fullscreen-button, I see a flicker as if it did got to full-screen, but then it stays standard size, kinda like a pop-up ad being killed by ad-block. - Some players have a "toggle fullscreen" option available on right-click menu, this is the only option that works for me now. In this case, I have to press and hold the right mouse button and release it over the "fullscreen" menu entry. The menu disappears when releasing the mouse button. - Only exception I found so far: Youtube, which works normally with left click on the fullscreen-button. My current Flash-plugin version is 11.2.202.285ubuntu0.13.04.1. I wonder if Gnome Shell might be messing with Flash? Is anyone else experiencing this problem? Edit: this problem is present in Firefox, Opera and Chromium browsers. The graphics card I'm using (as reported in Gnome settings > details) is GeForce 8100/nForce720a/integrated/SSE2

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

I found the following solution which worked perfectly for me:

Workaround fo this:

  1. Install devilspie (via Terminal:)

    sudo apt-get install devilspie
    
  2. Write config for firefox (via Terminal:)

    mkdir ~/.devilspie
    nano ~/.devilspie/flash-fullscreen-firefox.ds
    
    (if
    (is (application_name) "plugin-container")
    (begin
    (focus)
    )
    )
    
  3. Make devilspie autostart

Done.

Solution from: https://plus.google.com/100368718538258540940/posts/eJWwPj8B4dX (last post)

share|improve this answer
    
I'm stuck at step 3. How do you make a command line appplication autostart? Remember I'm on Lubuntu 13.04 with Gnome Shell. –  Bennypr0fane Jun 14 '13 at 22:55
1  
here's how I made the autostart work: in Gnome dash, search for "Startprogramme" (means autostart applications - my UI is in German!). In terminal, type: which devilspie , output: /usr/bin/devilspie . In "Startprogramme", click "add" and insert this output in the "command" field. Fullscreen Flash is now working again. –  Bennypr0fane Jun 18 '13 at 18:34
add comment

I created a devilspie script to make flash play videos full screen in Chromium and Firefox.

Save the following snippet to a file, make it executable and run it. (Tested on Fedora Linux 19 using yum instead of apt-get)

#!/bin/bash

set -e

sudo yum install devilspie

mkdir -p ~/.devilspie

echo '(if
(or
    (is (application_name) "plugin-container")
    (and
        (contains application_name) "chromium-browser")
        (contains application_name) "flash-plugin")
    )
)
(begin
(focus)
)
)' > ~/.devilspie/flash_fullscreen.ds

echo '#!/bin/bash

echo "running" > /home/maarten/devilspie.log

while [ true ]; do
  /usr/bin/devilspie;
done' > ~/.devilspie/devilspie_daemon.sh

chmod a+x ~/.devilspie/devilspie_daemon.sh

mkdir -p ~/.config/autostart

echo '[Desktop Entry]
Type=Application
Exec=/home/maarten/.devilspie/devilspie_daemon.sh
Hidden=false
X-GNOME-Autostart-enabled=true
Name[en_US]=Devilspie Daemon
Name=Devilspie Daemon
Comment[en_US]=Script will continuously restart devilspie if stopped
Comment=Script will continuously restart devilspie if stopped
' > ~/.config/autostart/devilspie_daemon.desktop
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.