Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The main problem is that I can't install Steam basically, but I tried with other applications too and none of those applications will install.

I run software center via terminal and this is the log that i get when i try to install steam.

I click on steam and then I click on buy, it redirects me to login and I login, so authentication pass and I'm logged in but I still get an error to buy application again and this time it won't redirect me to login, it just won't install.

Here's log file

2013-06-07 22:19:58,630 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/dbus/proxies.py', 410, '_introspect_error_handler')'
2013-06-07 22:19:58,630 - dbus.proxies - ERROR - Introspect error on :1.11:/org/freedesktop/NetworkManager: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.54" (uid=1000 pid=2318 comm="/usr/bin/python /usr/bin/software-center ") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply="0" destination=":1.11" (uid=0 pid=574 comm="NetworkManager ")
2013-06-07 22:19:58,630 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/netstatus.py', 122, '__init_network_state')'
2013-06-07 22:19:58,630 - root - WARNING - failed to init network state watcher 'org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.54" (uid=1000 pid=2318 comm="/usr/bin/python /usr/bin/software-center ") interface="org.freedesktop.NetworkManager" member="state" error name="(unset)" requested_reply="0" destination=":1.11" (uid=0 pid=574 comm="NetworkManager ")'
2013-06-07 22:19:58,759 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/netstatus.py', 151, 'test_ping')'
2013-06-07 22:19:58,759 - root - INFO - Attempting one time ping of archive.ubuntu.com to test if internet connectivity exists.
2013-06-07 22:19:58,781 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-06-07 22:19:58,784 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2013-06-07 22:19:58,880 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/netstatus.py', 168, 'test_ping')'
2013-06-07 22:19:58,880 - root - INFO - ping output: 'Internet connection available!
PING archive.ubuntu.com (91.189.92.201) 56(84) bytes of data.
64 bytes from urayuli.canonical.com (91.189.92.201): icmp_req=1 ttl=49 time=55.6 ms

--- archive.ubuntu.com ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 55.611/55.611/55.611/0.000 ms
'
2013-06-07 22:19:59,032 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-06-07 22:19:59,188 - softwarecenter.ui.gtk3.app - INFO - show_available_packages: search_text is '', app is None.
2013-06-07 22:19:59,197 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2013-06-07 22:20:06,863 - softwarecenter.db.database - INFO - reopen() database
2013-06-07 22:20:06,863 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2013-06-07 22:20:07,160 - softwarecenter.db.update - INFO - skipping region restricted app: 'Bulleti d'esquerra de Calonge i Sant Antoni ' (not whitelisted)
2013-06-07 22:20:07,493 - softwarecenter.db.update - INFO - skipping region restricted app: 'Comentarios Web' (not whitelisted)
2013-06-07 22:20:10,229 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
2013-06-07 22:20:10,229 - softwarecenter.db.database - INFO - reopen() database
2013-06-07 22:20:10,229 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2013-06-07 22:20:17,910 - softwarecenter.backend - INFO - add_repo_add_key_and_install_app() 'private-ppa.launchpad.net/commercial-ppa-uploaders/steam/ubuntu precise main' '33E0E91BDD8E7F4B53837F09E131728675254D99' 'steam-launcher'
2013-06-07 22:20:17,917 - softwarecenter.backend - ERROR - authenticate_for_purchase failed
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/backend/installbackend_impl/aptd.py", line 562, in add_repo_add_key_and_install_app
    yield self.authenticate_for_purchase()
  File "/usr/lib/python2.7/dist-packages/defer/__init__.py", line 473, in _inline_callbacks
    result = gen.throw(result.type, result.value, result.traceback)
  File "/usr/share/software-center/softwarecenter/backend/installbackend_impl/aptd.py", line 502, in authenticate_for_purchase
    yield policykit1.check_authorization_by_name(name, action, flags=flags)
AuthorizationFailed: org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.54'}): org.debian.apt.install-purchased-packages

From the last line I see authorization failed but I don't know if this is authorisation to Ubuntu but i have already logged in.

The second time when I tried to install the application I started software-center via terminal and went to file > install previous purchases, and there was steam. When I clicked I had install button instead of buy but still wasn't able to install it.

The same thing happens when I try to install filezilla or any other app.

I even reinstalled complete OS and again having same problem. Now i don't even have terminal to start it from there.

share|improve this question

1 Answer 1

It appears you have not authenticated to the Ubuntu SSO or you have an account problem. I would suggest opening a help desk ticket with [email protected]

share|improve this answer
    
I should mention that this is ubuntu installed on vps.I have reinstalled my os, and tried again, strange thing is that terminal output successful authentication when i try to login but when i try to download app it gets authorization failed. Ill send email to support and see what will they say. –  Aleksandar Đorđević Jun 10 '13 at 13:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.