Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been dealing with this problem for a couple of days but couldn't find a solution. I've posted on a forum before but nobody answered. Any help?

A couple of days ago a problem started to occur. I can't watch YouTube videos anymore. When I open a video, the animation goes on and on... until the message "an error has occurred". Very very very rarely sometimes a video loads. (Today it never happened, yesterday only once)

Like I said, a couple of days ago it was all working. I didn't do any updates. After this problem, I've installed every update, didn't solve the problem.

It is not browser specific, Google Chrome, Chromium, Firefox, Opera... All have the same problem. It is YouTube specific, I can watch videos on Facebook (not loaded through YouTube) and vimeo and more. I have reinstalled the flash-plugin, didn't solve. (Yet it is not about flash) It is not about my network, using the same network, Windows Laptop, iPhone, Android Tablet all load v

Ubuntu 12.04 LTS 32 Bit

$ uname -a
Linux marvin 3.2.0-45-generic-pae #70-Ubuntu SMP Wed May 29 20:31:05 UTC 2013 i686 i686 i386 GNU/Linux

$ dpkg -l |grep "chrome\|firefox\|opera\|chromium\|flash"
ii adobe-flash-properties-gtk 11.2.202.285-0precise1 GTK+ control panel for Adobe Flash Player plugin version 11
ii adobe-flashplugin 11.2.202.285-0precise1 Adobe Flash Player plugin version 11
ii chromium-browser 25.0.1364.160-0ubuntu0.12.04.1 Chromium browser
ii chromium-browser-l10n 25.0.1364.160-0ubuntu0.12.04.1 chromium-browser language packages
ii chromium-codecs-ffmpeg 25.0.1364.160-0ubuntu0.12.04.1 Free ffmpeg codecs for the Chromium Browser
ii eject 2.1.5+deb1+cvs20081104-9 ejects CDs and operates CD-Changers under Linux
ii firefox 21.0+build2-0ubuntu0.12.04.3 Safe and easy web browser from Mozilla
ii firefox-globalmenu 21.0+build2-0ubuntu0.12.04.3 Safe and easy web browser from Mozilla - Unity menubar integration
ii firefox-gnome-support 21.0+build2-0ubuntu0.12.04.3 Safe and easy web browser from Mozilla - GNOME support
ii firefox-locale-en 21.0+build2-0ubuntu0.12.04.3 English language pack for Firefox
ii google-chrome-stable 27.0.1453.110-r202711 The web browser from Google
ii libcrypt-passwdmd5-perl 1.3-10 interoperable MD5-based crypt() for perl
ii opera 12.15.1748 Fast and secure web browser and Internet suite
ii xserver-xorg-video-openchrome 1:0.2.904+svn1050-1 X.Org X server -- VIA display driver

Any suggestions? Sorry if it is a repost, it's hard to find this problem in the dozens of "restricted-extras not installed" problems...

share|improve this question
1  
did you fix it? I have exactly the same problem. –  fenerfan18 Jun 23 '13 at 10:22
    
Related: askubuntu.com/questions/301950/… –  belkinsa Sep 27 '13 at 1:22
    
Related: askubuntu.com/questions/135212/… –  belkinsa Sep 27 '13 at 13:22
    
@Barsook any reason to offer bounties to almost identical problems? –  Braiam Sep 28 '13 at 16:33
    
Wasn't thinking there, the last one is the question that is like this one the first one isn't- that seems to to be another issue. –  belkinsa Sep 29 '13 at 12:51
show 1 more comment

4 Answers 4

Re-install the Ubuntu Restricted Extras package.

share|improve this answer
add comment

Try the following

on your top panel

  1. Go To connections.
  2. Edit Connections
  3. Pick "Wired connection 1 (or whatever name it has)" and click on edit.
  4. Change MTU Value from Auto to 1492, and click on save.

I had the same problem before where it just showed me the animation with the little circles running and a few moments after, the message "there has been an error, try again later", if you have the same problem, then doing that should fix it, I was pointed in the right direction by a friend in this Question, just click on it and you'll see the comment.

Hope this solves your problem.

share|improve this answer
1  
Since you have the alt answer, I think you may get the points. –  belkinsa Sep 30 '13 at 22:43
add comment

Did you install the package called ubuntu-restricted-extras? You can do this in the Software Center or, if you prefer the to use the command-line, then by running sudo apt-get update followed by sudo apt-get install ubuntu-restricted-extras.

If you have ubuntu-restricted-extras, then verify that a Flash plugin is actually installed by checking for the adobe-flashplugin or flashplugin-installer packages. If neither is installed, install one of them. If you're running the 64-bit version of Ubuntu, installing adobe-flashplugin is preferable. (But don't have them both installed at the same time.)

If you're running the 64-bit version of Ubuntu and you find that you have flashplugin-installer installed and the problem continues, then try removing it and replacing it with adobe-flashplugin.

If none of the above works, check to see if you're using the HTML5 beta on YouTube! by going to http://youtube.com/html5. Theoretically, and eventually, this should perform uniformly better on Ubuntu. But right now, it might not work well. So if it's turned off, you can try it and see if it works better. If it's turned on, try turning it off and seeing what happens.

If you have trouble doing any of the above, please post a comment here. If you do the above but it doesn't work, please edit your question to indicate that it didn't, and also to include the output of this command (which you should run in the Terminal): dpkg -l | egrep 'flash|gnash|swf|spark'

Credits: Barsook

Real Answer by: Barsook

Source: Why do I have problems seeing YouTube?

share|improve this answer
    
As I've mentioned in the post, ubuntu-restricted-extras was installed, it's not related to that, and adobe-flashplugin was also installed. –  nukacolacolic Mar 3 at 15:42
add comment

I had this problem but it cleared up when I installed the Adobe flash plugin and made it the default. Youtube is set up for Adobe as their preferred flash. Also make sure libming1 is installed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.