Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an issue with terminal in Ubuntu 10.04. When I launch it, it hangs, like this:

teminal

I cannot do anything until I press Ctrl + C:

enter image description here

I cannot remember when this started. What can be wrong? Looks like teminal is loading or processing something each time it loads. How can I diagnose and solve this problem?

EDIT:

Here are the conents of ~/.bashrc:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoredups:ignorespace

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi

# Source .profile
if [ -f ~/.profile ]; then
  . ~/.profile
fi

Setting -x at the beginning showed me that it tries to repeat this without stopping:

+++++++++++++++++++ '[' 'complete -f -X '\''!*.@(pdf|PDF)'\'' acroread gpdf xpdf' '!=' 'complete -f -X '\''!*.@(pdf|PDF)'\'' acroread gpdf xpdf' ']'
+++++++++++++++++++ line='complete -f -X '\''!*.@(pdf|PDF)'\'' acroread gpdf xpdf'
+++++++++++++++++++ line='complete -f -X '\''!*.@(pdf|PDF)'\'' acroread gpdf xpdf'
+++++++++++++++++++ line=' acroread gpdf xpdf'
+++++++++++++++++++ list=("${list[@]}" $line)
+++++++++++++++++++ read line
share|improve this question
add comment

3 Answers 3

up vote 4 down vote accepted
+50

You are sourcing .profile from .bashrc, but .profile is already sourcing .bashrc (which is the correct way), so you've made an infinite loop. Do not source .profile from .bashrc.

See http://mywiki.wooledge.org/DotFiles

share|improve this answer
    
I've removed .profile stuff and it worked! Thanks a lot! –  Silver Light Mar 20 '11 at 17:04
    
Btw, I have remembered how it got there. I've added it when installed rabbitvcs using this tutorial: wiki.rabbitvcs.org/wiki/development/installation –  Silver Light Mar 21 '11 at 16:00
    
@Silver Light, That's definitely bad advice they're giving there. Instead of telling you to source ~/.profile from ~/.bashrc, they should just say "log out and back in again for ~/.profile to be reread" or something like that. –  geirha Mar 22 '11 at 6:46
add comment

Look in ~/.bash_profile or ~/.bashrc for programs that might be getting "stuck" (or, perhaps more likely, waiting for you to type something; beware of things like grep with missing file arguments). If necessary, you can add set -x at the top of either so the shell shows you what it's running before it runs it.

share|improve this answer
    
Thank you for your answer. I've added what i saw in ~/.bashrc I can't seem to see the problem. –  Silver Light Mar 15 '11 at 21:08
1  
That looks like /etc/bash_completion is corrupt somehow. Try reinstalling bash and bash-completion. –  geekosaur Mar 15 '11 at 21:18
add comment

Have you been editing your .bashrc (or similar files) recently? Stuff in there will execute before the prompt appears. The fact you can kill whatever is going on by pressing Ctrl-C suggests something is running.

I would suggest opening your home folder in the file browser, showing hidden files (Ctrl-H) and sorting by "Date Modified". Then look at the newer files. If there are any recently changed with a name like .bashxyz or .bash_xyz then you could rename them and try restarting the terminal again. A new version of the file will be generated when you start the terminal. If that fixes it then you can compare the new file and the renamed file for changes.

Other filenames to look out for are .profile and .inputrc.

Another approach would be to start one terminal and (after hitting Ctrl-C) run top in the terminal. Then start a second terminal and see what is running.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.