Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My girlfriends computer recently upgraded to 13.04. I have another computer running Fedora, several android devices, and my friend was over earlier with his Mac. The computer running Ubuntu 13.04 causes every other device to have ~30-40% packet loss while pinging my router and 8.8.8.8. As soon as I diconnect her computer from the network all of the other devices begin functioning correctly; actually it's not immediate; during tests the other devices report dropping the first one or two packets and then they start behaving correctly. This is mind-bonglingly repeatable.

The computer that is causing the issue is an HP Folio running Ubuntu 13.04. The wireless is Broadcom controller and using the wl driver.

$lspci -vv -s
Subsystem: Hewlett-Packard Company Device 1795
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 18
    Region 0: Memory at c2600000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
        Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
        Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=2 PME-
    Capabilities: [58] Vendor Specific Information: Len=78 <?>
    Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
        Address: 0000000000000000  Data: 0000
    Capabilities: [d0] Express (v1) Endpoint, MSI 00
        DevCap:    MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
            ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
        DevCtl:    Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
            RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
            MaxPayload 128 bytes, MaxReadReq 128 bytes
        DevSta:    CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
        LnkCap:    Port #0, Speed 2.5GT/s, Width x1, ASPM L1, Latency L0 <4us, L1 <64us
            ClockPM+ Surprise- LLActRep+ BwNot-
        LnkCtl:    ASPM L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
            ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
        LnkSta:    Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive+ BWMgmt- ABWMgmt-
    Capabilities: [100 v1] Advanced Error Reporting
        UESta:    DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
        UEMsk:    DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
        UESvrt:    DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
        CESta:    RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
        CEMsk:    RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
        AERCap:    First Error Pointer: 14, GenCap+ CGenEn- ChkCap+ ChkEn-
    Capabilities: [13c v1] Virtual Channel
        Caps:    LPEVC=0 RefClk=100ns PATEntryBits=1
        Arb:    Fixed- WRR32- WRR64- WRR128-
        Ctrl:    ArbSelect=Fixed
        Status:    InProgress-
        VC0:    Caps:    PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
            Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
            Ctrl:    Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
            Status:    NegoPending- InProgress-
    Capabilities: [160 v1] Device Serial Number 00-00-d3-ff-ff-08-7c-e9
    Capabilities: [16c v1] Power Budgeting <?>
    Kernel driver in use: wl

And here is some more info about the driver:

$modinfo wl
filename: /lib/modules/3.8.0-23-generic/updates/dkms/wl.ko
license: MIXED/Proprietary
srcversion: 6E2531203CF49EB24353067
alias: pci:v*d*sv*sd*bc02sc80i*
depends: cfg80211,lib80211
vermagic: 3.8.0-23-generic SMP mod_unload modversions
parm: oneonly:int
parm: piomode:int
parm: instance_base:int
parm: nompc:int
parm: intf_name:string

I found a similar issue on askubuntu.com It seems to be the exact same problem, but the solution, to remove the driver, would be unexeptable without a replacement driver and I really don't feel like rolling my own driver. Can anybody help me troubleshoot(and hopefully) fix this problem?

share|improve this question
add comment

2 Answers 2

I'd this very same issue as one of my laptops has a Broadcom 4313 wireless adapter. This particular issue appears to have been introduced in v6.20.155.1 of the drivers, but is solved in v6.30.223.30, which is the version due to be released with Saucy. Unfortunately, this version of the driver hasn't been backported to Raring, but thankfully the Saucy package is compatible with Raring.

The bug report on Launchpad includes instructions for installing the Saucy driver in comment #23. I'll reproduce them here for your convenience:

  • Go to https://launchpad.net/ubuntu/saucy/+package/bcmwl-kernel-source
  • Click the link under Source package
  • Under "Builds" click either saucy i386 (for 32-bit) or saucy AMD64 (for 64-bit)
  • On the next page, under "Built files", click the link to download the .deb file
  • Open the .deb and it should open in Ubuntu Software Center
  • Click the Upgrade button

I hope that fixes your problem and, with any luck, the driver might be backported properly at some point.

share|improve this answer
    
Worked like a treat, this has been bugging me for so long! –  Buchow_PHP Oct 16 '13 at 17:44
add comment

@shakabra, I've a creeping suspicion that the Mac computer is the culprit here. I've experienced loss of wi-fi connectivity by various devices on my home network every time I turned on my MacBook or iPad. There are known issues with wi-fi implementation on Apple devices. I can't go into details here, but you can easily google the topic as it is widely discussed.

I did not dig deeper since it is a problem I can live with for a while, and I hope for a fix from Apple in their next update to iOS and OS X. Hope that helps. Cheers.

share|improve this answer
    
No. The problem is definitely the Ubuntu computer. –  shakabra Jun 13 '13 at 18:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.