Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To use vmware player, it is asked me to update headers to 3.9.0-1-generic. I tried to update it by using;

sudo apt-get install build-essential linux-headers-$(uname -r)

But it is failed and it respond like;

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package linux-headers-3.9.0-1-generic is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'linux-headers-3.9.0-1-generic' has no installation candidate

My Ubuntu is upgraded from 12.10 to 13.10 and I doubt that there might be some buggies because of upgrading.

Because of this problem I can't use vmware player.

Thank You!

Edited

Current Ubuntu Version is 13.10

share|improve this question

closed as off-topic by Braiam, guntbert, Olli, karel, BuZZ-dEE Mar 1 at 10:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – guntbert, Olli, karel, BuZZ-dEE
If this question can be reworded to fit the rules in the help center, please edit the question.

    
3.9 is not the out of the box kernel for 13.04. You should use 3.8.0-23-generic or newer and install its header packages. –  Terry Wang Jun 7 '13 at 6:56
    
How can I make it use 3.8.0-23? –  Whispered Jun 7 '13 at 7:03
    
If you are running 13.04, just apt-get install linux-image-3.8.0-23-generic to install, it should be taken care of by this package linux-image-generic. –  Terry Wang Jun 7 '13 at 12:34
    
Still able to reproduce it? –  Braiam Feb 28 at 15:38
1  
@Braiam actually I am not using 13.10 anymore. I don't know what would the situation be right now. But the problem was about upgrading it from old version and this was specific case. –  Whispered Feb 28 at 16:46
show 1 more comment

2 Answers 2

linux-headers-3.9.0-1-generic is available for Ubuntu Saucy -13.10 . I think you are trying to install vmware player for that version.

try to get vmware player for 13.04 not for 13.10.

share|improve this answer
    
Where can I find vmware player for 13.04? I see only one vmplayer on their official website. –  Whispered Jun 7 '13 at 6:59
    
I am sorry I though my version was 13.04 but it is 13.10 –  Whispered Jun 7 '13 at 7:15
add comment

Hate to say this (really!!) but upgrading from Vmware Workstation 9.x to 10.X solved this problem for me on Ubuntu 3.10.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.