Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Ctrl+Alt+Arrow key fails to switch my workspace, but this is only true if

  1. NumLock is on
  2. I press Ctrl followed by the Alt key
  3. I'm using the left Alt key
  4. I'm logged in as me (as opposed to a guest)

Any help debugging this weird behavior would be greatly appreciated. It's a pretty frustrating little bug that gets in my way at least 20 times a day, and it's so strange that I would really just like to understand how it could be happening, although I wouldn't mind just fixing it with some kind of keybindings/unity/compiz reset. I just need some pointers on how to achieve this reset. Thanks!

share|improve this question
I have almost the same problem in 13.04. It's working only in guest mode with Ctrl + Left Alt + Arrow keys (nothing to do with NumLock). – Radu Rădeanu Jun 9 '13 at 9:29
Did you try turning it off and on again? Workspaces, that is. – Jun 9 '13 at 21:23
I didn't try toggling it through that menu. I was thinking it's a keybinding problem, since workspaces works fine, it doesn't get triggered by a very specific key sequence. – Noah Jun 10 '13 at 18:55

I've solved it by enabling Desktop Wall in CompizConfig Settings Manager:

Desktop Wall - CCSM

share|improve this answer
I had Desktop Wall enabled. I tried toggling it to no effect. – Noah Jun 10 '13 at 18:54
@Noah For me this worked. – Radu Rădeanu Jun 10 '13 at 19:06
This worked for me as well. – Stefan Radovanovici Sep 20 '13 at 13:20
I had to disable the shortcuts in Window Management after installing CompizConfig Settings Manager. – geneorama Mar 19 '15 at 6:34
It also works in 15.10 – Cysioland Jan 21 at 20:39

I had a similar problem running on a virtual machine and it turned out that VMWare Workstation was capturing / to switch between active virtual machines.

In WMWare Workstation > Virtual Machine > Preferences > Hot Keys, I changed the hot key combination to CTRL+ALT+Windows Key

share|improve this answer

I've you've come here (like me) for the title alone (Ctrl+Alt+Arrow key doesn't switch workspaces) then additionally to other answers here, try increasing the SIZE of your desktop:

Compiz > General settings > "Desktop size" tab > if it's 1x1, increase it

Credit to Uchiha Madara's comment in another question.

share|improve this answer
this fixed my problem! thanks – garnav Apr 13 '15 at 11:36

I ended up deleting anything in my home that sounded like a gnome or unity thing (.gconf, .gnome2, .kde). It obliterated all my unity settings, but it fixed the problem. I'm still curious to know how I could have done a more targeted fix.

share|improve this answer

Have the same problem since today. This bug?

It seems that only (compiz Config Settings manager) CCSM is able to change workspaces from now on. - general options - Unity plugin

The Unity Tweak tool doesn't do anything since today. It shows the wrong amount and changing it doesn't do anything.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.