Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm experiencing a strange thing, I've freshly upgraded from 12.10 to 13.04, Everything is fine except that it can't build the initrd image automatically, it fails and prints out the mkinitramfs's Usage output.

I tried to debug the "mkinitramfs" script and it appears the $outfile variable is never set. However, I'm able to produce the ramdisk manually like follow: update-initramfs -c -u 3.0.8-23-generic

I tried most of the stuff seen on the net: purge, reinstall but no help but nothing, and I can't use linux-image is marked as "broken" but the kernel exists in /boot.

share|improve this question
    
I intented to but the dialog window you get by clicking on "answer your question" is not clear. BTW, it was not necessary to remove my update msg, I don't want to retype it. –  Phil2.0 Oct 19 '13 at 3:02
    
thank you Mateo –  Phil2.0 Oct 19 '13 at 9:34

1 Answer 1

I was able to fix it, it seems that the kernel postinstall scripts is not compatible with my version of mkinitramfs (initramfs-tools 0.103ubuntu0.7).
In the linux-image postinstall script file, the call lacks of a parameter:
at line 837:

my $ret = system("$ramdisk " . ($upgrading ? "-u" : "-c") . " -k " . $version . " >&2");  

should be (Note the -o parameter before the $version variable.)

my $ret = system("$ramdisk " . ($upgrading ? "-u" : "-c") . " -k " . " -o " . $version . " >&2");

And it works! I was always bypassing this issue with a manual update-initramfs but I didn't like the fact that each time I used apt-get, dpkg status kept printing this error which fortunately was not blocking, then I had some spare time tonight and decided to put these on this annoying stuff and it pays off! =)

Unfortunately, it doesn't explain why an how I got this issue after an distro-upgrade of my Ubuntu server using the official repositories. :/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.