Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I tried to install X3: Reunion (Linux Distribution) on Ubuntu 13.04 32-bit. My laptop uses the Intel Graphics 4500HD. Ubuntu's driver alternative- installed: Intel® Ironlake Mobile x86/MMX/SSE2. (This driver was there, when I installed Ubuntu. I also used the Intel Updater, but the Intel Updater keeps informing me, that I already have the newest driver installed) Is my graphics driver correct?

I ask because after I installed X3: Reunion (Linux Distribution) the game hasn't been able to start. I have already searched the internet for many many hours. Even so I haven't been able to find any answer to the errors (check below). I am not sure if it's my driver or a bad game install (I already tried to re-install the game). I have heard that there are others who experienced similar issues on Linux trying to install games. Maybe someone can help me?

When I start the game launcher, I get this error (let's call it, Error 1):

Gtk-WARNING **: Failed to load module "liboverlay-scrollbar.so": liboverlay-scrollbar.so: cannot open shared object file: No such file or directory
libGL error: failed to load driver: i965
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.

When I click on Start Game I get this error (let's call it, Error 2):

    /lib/i386-linux-gnu/libc.so.6(vsprintf+0xa4) [0xb6bce9f4]
    x3() [0x817ed00]
    x3() [0x81539d5]
    x3() [0x81773b2]
    x3() [0x80cc251]
    x3() [0x81515fa]
    /lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0xb6b7f935]

I use Ubuntu 13.04 32-bit. That's what I know. I am obviously new to Linux. All I need is this game. I'd like to play it once in a while. But I'm not experienced enough to solve these errors. One more thing. Even that I get "Error 1" when opening the launcher, the launcher itself runs fine. When I click on "Start game" I actually get two messages. Error 2 in the terminal and the following message in the launcher(lgp):

Error opening video. There is no VESA driver installed, your graphics adapter or the VESA driver doesn't support the resolution. Further information can be found in the manual.

Well, I already read the "manual" (I wouldn't call it a manual, though). I thought VESA was used in Nvidia Graphics? xD
I chose the 1600X900 resolution, my native resolution. - Yes, I already tried to change the resolution. Once I start the game with another resolution, the error disappears. But the game does not work!

So, basically, what are these errors? (Error 1 and 2) Is my graphics driver correct? (Intel 4500HD) Why doesn't this game start? (X3: Reunion)

share|improve this question
Welcome on-board this Ubuntu forum :-) You should check the egosoft linux forum at forum.egosoft.com/viewtopic.php?t=332472 To me this game is one of the few reasons I boot on windows nowadays. I had an unused win7 license lying around, so I installed it on an old external 80GB usb drive and installed X3 Reunion on it. Works like a charm and my system is not "polluted" with "small and soft" partitions. It is good to make proffitssss with you :-) –  hmayag Jun 6 '13 at 23:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.