Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How I attempted to install bumblebee:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

Using this script, I have the following output about my graphics / xorg setup. https://gist.github.com/NullVoxPopuli/5724159

Output:

Graphics Card(s): 
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 730M] (rev a1)

Connected Monitors: 
[     7.244] (II) intel(0): Output LVDS1 connected
[     7.244] (II) intel(0): Output HDMI1 connected

Current Video Driver: 
drm_kms_helper         49394  1 i915
drm                   286313  4 i915,drm_kms_helper

Video Output Locations: 
/dev/video0
/dev/fb0
/dev/dri/card0
/dev/dri/controlD64

Grub boot command: 
BOOT_IMAGE=/boot/vmlinuz-3.8.0-23-generic root=UUID=465876a7-4c66-4160-822f-9c1d5cd30037 ro quiet splash vt.handoff=7

modprobe.d drivers: 
/etc/modprobe.d/
/etc/modprobe.d/blacklist-modem.conf
/etc/modprobe.d/bumblebee.conf
/etc/modprobe.d/blacklist-oss.conf
/etc/modprobe.d/nvidia-304_hybrid.conf
/etc/modprobe.d/alsa-base.conf
/etc/modprobe.d/blacklist-firewire.conf
/etc/modprobe.d/blacklist.conf
/etc/modprobe.d/mlx4.conf
/etc/modprobe.d/blacklist-rare-network.conf
/etc/modprobe.d/blacklist-framebuffer.conf
/etc/modprobe.d/blacklist-watchdog.conf
/etc/modprobe.d/iwlwifi.conf
/etc/modprobe.d/vmwgfx-fbdev.conf
/etc/modprobe.d/dkms.conf
/etc/modprobe.d/blacklist-ath_pci.conf

Do we have a xorg.conf file?
ls: cannot access /etc/X11/xorg.conf: No such file or directory

glxinfo: 
/home/me/scripts/which-graphics-driver: line 25: glxinfo: command not found

Drivers loaded by Xorg: 
[     5.954] (II) LoadModule: "glx"
[     5.958] (II) LoadModule: "intel"
[     5.961] (II) LoadModule: "vesa"
[     5.962] (II) LoadModule: "modesetting"
[     5.963] (II) LoadModule: "fbdev"
[     5.966] (II) LoadModule: "fbdevhw"
[     7.244] (II) LoadModule: "dri2"
[     7.523] (II) LoadModule: "evdev"
[     7.534] (II) LoadModule: "synaptics"

I'm using Ubuntu 13.04

UPDATE (summary of comments):

optirun app-name produced an error, so I installed the package it suggested (mesa-utils, I think?) and tried optirun firefox and got this error:
[ 2971.281588] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver [ 2971.281649] [ERROR]Aborting because fallback start is disabled.1

Next, was to check the /etc/bumblebee/xorg.conf.nvidia file, and see if it had the correct BusID. It didn't, so I changed it from PCI:01:00:0 to PCI:01:00.0.. but I got the same error. :-(
Here is my current /etc/bumblebee/xorg.conf.nvidia file if anyone is curious: http://pastebin.com/HreaubsF

it was suggested that I run glxinfo from the terminal, but that has a TON of output that I don't know how to read.

As of June 12th, 2013 9:48pm EST, I still have this error when trying to use optirun:

$ optirun firefox
[111951.191738] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[111951.191804] [ERROR]Aborting because fallback start is disabled.
share|improve this question
1  
You have to run optirun app-name in terminal to use the nvidia card. Everything else will the integrated graphic card be used for.. –  aXept Jun 6 '13 at 19:29
    
this is what I get when I do optirun <anything> [ 2971.281588] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver [ 2971.281649] [ERROR]Aborting because fallback start is disabled.1 –  NullVoxPopuli Jun 6 '13 at 19:41
    
Hm, strange.. When I run that script I got allmost the same, apart from GLXinfo, where I got things right.. But I have nvidia-current installed... –  aXept Jun 6 '13 at 19:52
    
when I was watching bumblebee install, I saw it also included nvidia-304 and nvidia-current. so.. I have the packages installed. I guess they just aren't active? –  NullVoxPopuli Jun 6 '13 at 20:08
1  
Try to run lspci | egrep 'VGA|3D' in terminal.. –  aXept Jun 6 '13 at 20:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.