Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to setup a 3g data connection on ubuntu touch preview (latest raring build)

But if I try to start with "nmcli con up "O2 connection 1" I get the error:

Unknown parameter: O2 connection 1 ERROR: id or uuid has to be specified

Here is my config file created from nm-connection-editor:

[connection]

id=O2 connection 1

uuid=ec4ef9f6-f466-4e18-b250-4437b208bd45

type=gsm

autoconnect=false

[gsm] number=*99#

apn=internet

network-type=0

[ipv4] method=auto

[serial]

baud=115200

Can someone help me with this issue?

id and uuid are in the config file.

Thanx a lot !!!

Greets andi

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

If you do con up you need to provide id or uuid, but you need to specify also if next parameter is "id" or "uuid".

Short answer: you need to add id parameter before id value:

nmcli con up id "O2 connection 1"

instead of:

nmcli con up "O2 connection 1"    # <--- missing "id"
share|improve this answer
    
OHHH shame on me :-( yepp i forgot this...but now I got the error "Unknown connection" What could that be? –  andi friede Jun 6 '13 at 19:23
    
I would try via uuid. BTW, I see you are new here. Remember to upvote, and select best answer :-) –  Michał Šrajer Jun 6 '13 at 19:39
    
Oh sorry Michal - how do I do this? –  andi friede Jun 6 '13 at 19:45
    
OK - I tried nmcli con up uiid "O2 connection 1" but same error :-(.....UNKNOWN CONNECTION –  andi friede Jun 6 '13 at 20:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.