Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a lenovo x230 running Ubuntu 12.04 LTS. I've been using it just fine for a while, but all of a sudden the internet's stopped working. It's connected to the router just fine (I can see the antenna bars saying it's connected) but when I try to go to a webpage, it's just loading forever. I've tried the fix listed here


but it hasn't done anything (the instructions are a little confusing though). I'm booting Windows 7 right now and the internet works just fine when I'm on Windows, so I know it must be a problem with Ubuntu. I haven't touched any network settings before this problem happened, and I've been using it just fine for months, so I don't know why I'm getting this problem all of a sudden.

Oh and I haven't updated anything in a few weeks (you know when the update manager pops up every so often listing all the things there's an update for) so I know it's not some update that broke it.

share|improve this question
Open a terminal (Ctrl+Alt+T), and type these commands separately: ifconfig, route -n, cat /etc/resolv.conf, ping -c 4, and ping -c 4 Copy their outputs and paste them in your question. – Alaa Ali Jun 6 '13 at 18:13
I put my results in a gist because they're a little long. Thanks so much for your help – Philip Jun 6 '13 at 19:02
I would also like to see: lspci -nn | grep 0280 – chili555 Jun 6 '13 at 19:12
it just displayed my network card model, intel centrino advanced n 6205 (i saved the exact output in a txt file then rebooted to windows, but something's wrong with the file. It just printed out the one line with my network card name though). – Philip Jun 6 '13 at 19:24
At the end of that line, there's a [ven_id#:dev_id#], I guess that's what he wanted to see =). – Alaa Ali Jun 8 '13 at 12:45

Possible solution (I have the same laptop):

sudo rmmod iwldvm
sudo modprobe iwlwifi 11n_disable=1
sudo modprobe iwldvm

Now, this only worked for me. I don't actually know what this code does, so use at your own risk.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.