Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Xubunu 13.04, but it didn't detect my wireless card. this is my wireless card :

Broadcom Corporation:BCM4312 802.11b/g LP-PHY: Wireless 1397 WLAN Mini-Card

I googled about it, and I found this solution :

Once you have confirmed that your WLAN device is supported, you may proceed to installing the driver by running the following command from Terminal window.

sudo apt-get install firmware-b43-installer

The problem is that I can't run this command in terminal, because I've no connection in xubntu, and for the moment I'm posting this thread from Windows.

I downloaded the package firmware-b43-installer from debian, and when I tried to install it, it gold me that I need the b43-fwcutter package so I download it, and when I tried to install it the terminal shows me that the installation needs some sources from the internet.

I don't have an Ethernet or some other internet connection source, the only way I can access to internet is from Windows.

How can I install my wireless card driver offline ?

share|improve this question
    
No idea .. ???? –  Aimad Majdou Jun 6 '13 at 18:07
add comment

2 Answers 2

up vote 1 down vote accepted

I have done it on Xubuntu 12.10 (Quantal Quetzal):

  1. Download firmware-b43-installer and b43-fwcutter from Ubuntu, choose the target release version (I chose Quantal) and architecture.

    • Alternatively, if you have a Live CD or installed *Ubuntu of the same release with Internet access, you can do: apt-get -d install firmware-b43-installer and then look for both packages in /var/cache/apt/archives. Do not use packages from different releases.
    • Do not download from Debian. Being a derivative does not imply that they are compatible, and does not imply that Debian's packages are suitable for Ubuntu.
  2. On the target machine, do dpkg -i b43-fwcutter* && dpkg -i firmware-b43-installer*

    • b43-fwcutter is a dependency of firmware-b43-installer, so it must be installed first.
share|improve this answer
add comment

I believe the package you need is linux-firmware-nonfree. http://packages.ubuntu.com/raring/all/linux-firmware-nonfree/download

Please download the package, transfer it on a USB stick or similar to the desktop of the Xubuntu machine. Open a terminal Ctrl+Alt+t and do:

sudo dpkg -i Desktop/linux*.deb
sudo modprobe -r b43 && sudo modprobe b43

You should be all set.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.