Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have searched high and low and nothing seems to work. I bought this Lenovo p500 IdeaPad, got rid of Windows8 and threw Ubuntu 12.04 on here.

My Centrino Wireless-N 2230 card seems to be giving me trouble. It will be at full speed at times (25MB down / 5.5 MB up) then drop to almost nothing (~2MB down / `0.5MB up) for no reason what so ever. Usually within 5 minutes of rebooting.

I have tried everything out there on the web. I have disabled Wireless N, I have turned off Power Management, I have disabled ipv6, etc etc. Most changes seem to work initially and then not at all. So is there a solution someone may have or help in the matter. It has been a couple years since I have used Linux, so any help with commands and trouble shooting would be greatly appreciated.

Here are some terminal stuff:

rfkill list

1: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
5: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: no

iwconfig

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"Birchcrest"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 68:7F:74:D4:0A:FA   
          Bit Rate=54 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=50/70  Signal level=-60 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:130  Invalid misc:203   Missed beacon:0
share|improve this question

2 Answers 2

I have a Toshiba Portege z935 which had the same or similar issue. I believe there is a bug that won't allow Bluetooth and WLAN to operate at the same time on this card. To solve it, reboot into BIOS and disable Bluetooth in the Advanced settings (may be different on your model of computer).

Once Bluetooth was disabled, my WLAN worked fine.

share|improve this answer

Go to Settings -> Additional Drivers and select the recommended proprietary wireless driver. Reboot to Ubuntu and see if your wireless is working.

share|improve this answer
    
No proprietary drivers found when I go to additional drivers –  John O Jul 6 '13 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.