Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have installed Ubuntu 12.04LTS on an external USB HDD, and put the bootloader onto the same drive. This is so I can interrupt the boot sequence on the PC and force the system to boot from the external drive when I want to use Ubuntu. (and at other times the PC will still boot seamlessly into Windows from the internal HDD for the rest of the family to use).

When I try to boot from the external drive, however, it drops into the "Grub Rescue" prompt.

I have tried several suggestions, including reinstallation, and repairing or reinstalling GRUB from the command line of the live CD. None of these have resolved the problem.

I have seen several similar postings on various Ubuntu sites, and I wonder if there are technical issues preventing running Ubuntu from an external USB drive in this way? (Until recently I had Mandriva, and this worked fine). Is it simply that the external USB HDD does not respond quickly enough for the system? Does Ubuntu need to be on the internal HDD?

share|improve this question

marked as duplicate by Mitch, Uri Herrera, Radu Rădeanu, Thomas W., user68186 Jun 7 '13 at 12:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

Try live installation instead of full install. There could be some differences in booting via USB. You can try this steps: http://www.pendrivelinux.com/installing-ubuntu-to-a-usb-hard-drive/ but it is a bit obsolete (Ubuntu 7), or to try to divide HDD following this steps: http://www.linuxbsdos.com/2011/05/23/install-ubuntu-11-04-on-external-hard-disk/

let us know if something from this options work for you.

Additionally, there is similar question to 12.10, which could have the very same resolution: How to run full ubuntu installation from external hard drive?

But most probably best steps you can find here: http://ubuntuforums.org/showthread.php?t=2084736

Happy installation!

share|improve this answer
1  
Thanks, Dee. I think ubuntuforums.org/showthread.php?t=2084736 has the answer, in particular the post "grub is broken for external drives" I had a quick look last night, but hope to try properly at the weekend... –  Martin Edgar Jun 7 '13 at 11:09
1  
Resolved this after considering notes about drive allocations... I had put the swap partition as the first partition on the hard disk. Changed this so the root partition was the first, and it now boots OK. –  Martin Edgar Jun 10 '13 at 19:44
    
yes, exactly, thats the difference, thank you for sharing this. If this lead to solution, you can edit the answer or just make a new one and mark it as accepted. –  Dee Jun 11 '13 at 22:36

when usb-harddisk resp. usb-stick is newer than bios of your machine allows this, then it happens that your usb-device is simply not recognized.

In this case bios-update (under windows) is necessary.

But you said, you were able to install ubuntu on to an usb-hard-drive ?

ah yes, you simply should set a "boot-flag" on to your usb-hard-disk with gparted. try it with an live-system like knoppix.

I think "boot" as flag is missing on your usb-hard-disk.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.