Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Thinkpad x41 tablet, under Ubuntu 12.04 / since a few hours 13.04.

Few days ago I tested a second Monitor 22", switched monitor view by fn-F5 and installed the Catalyst Control Center but didn't use it (because I don't have an AMD? Whatever, CCC didnt't work or even start).

Since then my Ubuntu Desktop has changed:

  • browsers / windows have no frames
  • the launcher is missing
  • the menu bar is missing
  • can't change window size

This stays the same on the intern laptop screen, also on an extern screen.

Beside these effects, the PC seems still to work fine, can browse, start programs by the terminal,....

Anybody an idea what I've might done? Could the Monitor effect the Laptop itself? Do launcher, window frames and menue-bar all depend on a single driver or preference setting?

Just noticed, when I start firefox via terminal I get this answer, firefox runs although (with the described symptoms of the window -size and -style):

(process:2214): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

share|improve this question
    
Have you connected the monitor again an used the control panels function Monitors to set the display "back" to internal? –  Manuel Jun 6 '13 at 12:03
    
Have you tried turning it off and on again? ;-) I guess so since it's been a few days but I thought it won't hurt to ask. –  André Stannek Jun 6 '13 at 13:57
    
@ stonedsquirrel: I've turned it off and on again several times :D didn't work :( –  Paul Jun 6 '13 at 15:03
    
@Manuel: I only got the function in the system control panel called Displays (or "Anzeigegeräte" on mine), there I was only able to switch one Monitor off. No function like back to internal. This problem stays regardless on which monitors I use. –  Paul Jun 6 '13 at 15:17
    
My first attempt to fix this was a try by the CCSM (CompiConfig), I installed it after the problem appeared. In the CCSM I saw that the Ubuntu Unity Plugin isn't aktivated. Tried to activate it everal times, but it's every time set back to NOT ACTIVATED. A look in the terminal, in which I started CCSM, shows: compizconfig - Info: Backend : gsettings compizconfig - Info: Integration : true compizconfig - Info: Profile : Default Loading icons... Does the last line indicate a failure in CCSM, could I look another place to fix the problem at anothe place? –  Paul Jun 6 '13 at 15:18
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.