Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a USB cooldisk 8.0 GB. it was full of Windows viruses. I tried to delete them under Ubuntu 13.04, but it didn't allow me to delete anything!

I formated it by the software 'Disks' to FAT filesystem and overwrite all data by zero. Again, I can't delete anything! I can't change permission of any file!

But, I can do anything by Terminal (CLI). I can create folder by mkdir. I can copy files by cp. etc. I ran sudo chmod 777 -R /media/me/USB/*, but the permission did not change: enter image description here

I want do all by Natilus. It does not allow me to create folder, copy, change permission, ..., by Natilus (Files).

What's the problem?

share|improve this question
Please post the output of mount after you plugged in an mounted the USB stick. – Manuel Jun 6 '13 at 12:26
do you mean "I can't do anything...." at the beginning of the third paragraph? – Trevor Clarke Dec 31 '15 at 3:10


Delete All files

If you run Disk Management, and click on the usb drive (SD card in the example below)

enter image description here

Click on the gear symbol (circled in red) and format the drive. this will clear it of all files.


Delete individual files

if you do not want to delete them all, open terminal with Ctrl + Alt + T and type in the following

sudo nautilus

Then navigate to your drive and delete should then work as the sudo command before nautilus gives Nautilus root privileges.


If you still can not access files

You should be able to change permissions by

  • mounting it with root nautilus (su then after entering the password, type nautilus)
  • then navigate to the drive and transferring permissions to 'guest'.
share|improve this answer
As I said, I've formatted it once! I also ran gksudo nautilus /media/me/USB => failed to copy/paste/delete/etc. – mini Jun 6 '13 at 18:23
Try formatting to one of the Linux formats – SimplySimon Jun 6 '13 at 18:42
It should be FAT! I use it in my car for listening to music. the player of car just supports FAT systemfile! – mini Jun 6 '13 at 19:00
You should be able to change permissions by mounting it with root nautilus (su then after password, nautilus) and transferring permissions to 'guest'. – SimplySimon Jun 6 '13 at 19:11

Try formatting it into ext4 format, then again format it in FAT. And you can also try the command , sudo rm /media/me/USB/* . Be sure to copy your files before formatting.

share|improve this answer

I had the same problem. I don't know how it happened, I also used the gnome disk management app, and somehow my directory in /media had the wrong ownership:

drwxr-x--- 1 root  root  0 Sep 28  2012 me

I deleted it (after unmounting all media), plugged in a usb drive and the directory has been recreated correctly:

drwx------ 1 me    root 18 Mai  1 01:59 me

Now everything's fine again.

share|improve this answer

It is not necessary to format the flash drive or to nuke the partition. You can go to mount and then change the ownership of your flashdrive. On ubuntu :

cd /media
sudo chown -R username drivename

Of course replace username by your username and drivename by the name of your flash drive.

Then you will be able to use nautilus as usual to copy/move/delete your files.

share|improve this answer
He said he wants to do it all from nautilus – anonymous2 Jul 1 at 1:33
Well yeah after that he will be able to use nautilus as usual. Edited, thanks – Richard Jul 1 at 1:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.