Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install or remove items I'm unable to do so due to 3 programs that aren't fully installed. Ive tried removing them and reinstalling but no luck when I tried to configure I got this:-

sudo dpkg --configure -a
Setting up linux-image-extra-3.8.0-23-generic (3.8.0-23.34) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-23-generic /boot/vmlinuz-3.8.0-23-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-23-generic /boot/vmlinuz-3.8.0-23-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-23-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.8.0-23-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-extra-3.8.0-23-generic.postinst line 1010.
dpkg: error processing linux-image-extra-3.8.0-23-generic (--configure):
subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-generic:
linux-image-generic depends on linux-image-extra-3.8.0-23-generic; however:
Package linux-image-extra-3.8.0-23-generic is not configured yet.

dpkg: error processing linux-image-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-image-generic (= 3.8.0.23.39); however:
Package linux-image-generic is not configured yet.

dpkg: error processing linux-generic (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
linux-image-extra-3.8.0-23-generic
linux-image-generic
linux-generic

How would I go about fixing this problem? I know it says no space left but I only updated a while ago and don't have any files as I just browse the internet and that error came after trying to update.

share|improve this question
    
gzip: stdout: No space left on device is the key, do you have enough space in all the partitions? –  Leo Jun 6 '13 at 10:23

1 Answer 1

If the terminal isnt your speed, try to run the computer janitor in ubuntu tweak. It will clean out /boot and many more... Follow directions here to install http://www.webupd8.org/2013/04/download-ubuntu-tweak-084-now.html

If you are comfortable with the terminal or trying to learn more about linux, then follow the steps taken here: http://ubuntuforums.org/showthread.php?t=1435818

Brought to you by google :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.