Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i m using ubuntu 12.04 LTS version on my asus laptop(64bit). My problem is that i cant get connected to network(wifi/wired LAN). System not showing any connections which are available. But i can get internet through a wireless usb modem. What i m missing here????

rfkill list all

0: asus-wlan: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: asus-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
4: phy2: Wireless LAN
Soft blocked: no
Hard blocked: no

I tried this- sudo rfkill unblock all still no change. plz replay....thnx

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This is probably a driver issue. Please, check your wireless and wired adapter type and see whether you have the correct drivers.

One other solution would be to upgrade to Ubuntu 13.04, which will probably contain newer drivers.

If you insist on 12.04, then try the compat-drivers (http://wireless.kernel.org/en/users/Download/stable).

When I was using 12.04, compat-drivers did it for me. In 13.04, I had no issues with network adapter drivers.

Best of luck!

share|improve this answer
    
Thnx for replaying. I downloaded the compact driver as you said. But i dont know what to do with that file.. m not expert in ubuntu. Can you help me with that?? thnx. –  Salih Jun 6 '13 at 10:56
    
Wow, finally i got it right. I m now able to connect through wifi.Installed a compact driver successfully. thanku again –  Salih Jun 6 '13 at 11:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.