Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So i have an issue with Truecrypt after moving across from my Mac OSX. Treucrypt file container created in MacOSX, now living in my Ubuntu home folder.

Now when I mount my Truecrypt volume (asks for TC & Ubuntu administrator password) and tried to write anything to or within it it comes up as an error that the destination is read-only. Can read the files as normal.

I've checked the volume properties in Truecrypt, - it was NOT created as a read-only volume. When I mount the volume in Truecrypt for each session the 'Mount as read-only' option is NOT ticked.

I've a feeling this is an Ubuntu permissions issue or step that I'm missing. I've been mounting from the GUI.

Can anyone please enlighten me as to how to get write priveleges with the mounted container?

Thanks in advance

share|improve this question

Depending on the file system used, this might help:

$ cd /media/truecrypt1
$ sudo chown -R $USER .

It sets the ownership of all files inside the encrypted file system to the currently logged in user.

share|improve this answer
I can confirm that this does the trick. – don.joey Feb 3 '14 at 18:52

I my case, I had to disable journaling on the Volume first. (I was mounting a fully-encrypted external hard-disk created on a Mac.)

On the Mac I did as described here:

diskutil disableJournal /Volumes/myVolume

Afterwards I did what pcworld said. chown. Then it worked.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.