Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hokay so...on my home network I'm running Ubuntu 12.04 LTS Server as a file server. I can SSH in and communicate with that server no problem. I have a home automation panel I wrote for the various devices on the network that was running on the file server. Since I have an older Lenovo Thinkpad SL410 with a broken screen lying around, I decided that I wanted to run the panel on the Thinkpad instead of the file server. So I installed Ubuntu 13.04 Desktop on the Lenovo. So far so good. The issue comes in that, for some reason unbeknownst to me, the file server can't communicate with the Lenovo. From my MacBook I can communicate with both. Since the MacBook is connected to the WiFi (as is the Lenovo) I can only surmise that it isn't an issue with the networking devices, but something with my config.

Here is a network diagram:

enter image description here

Just to reiterate: 10.0.0.247 can talk to both 10.0.0.200 and 10.0.0.201. However, 10.0.0.200 can't talk to 10.0.0.201 (and vice-versa).

I've made sure UFW is disabled (it's unnecessary internally). Pings fail with no routing errors, just 100% failure. SSH times out. Traceroute also never gets anyway.

Ask any clarifying questions and I'll do my best to answer them!

Edit: solved...a hard router reboot seems to have fixed it. Weird!

share|improve this question
    
This wifi extender device on your network, does it have any embeded logic? Is it possible it interferes in some way? Quick and dirty check: plug your thinkpad on the wired switch and try pinging your machines. –  hmayag Jun 5 '13 at 21:04
    
AFAIK there's nothing - it's in client mode, so it doesn't NAT or anything. Plugging it into the switch is the next thing I'm going to try, just have to grab some extra fly leads today:) –  fluffyponyza Jun 6 '13 at 7:01

2 Answers 2

UFW is disabled for 10.0.0.201 and 10.0.0.200? If not, try that.

Also look at /etc/hosts.deny and make sure the IP of each is not there.

I doubt this could be the problem, but check the netmask and make sure that all of your computers are in the same subnetwork.

share|improve this answer
    
Turns out a hard router reboot fixed the problem, guess that'll teach me to problem solve late at night:) Thanks for the assistance! –  fluffyponyza Jun 6 '13 at 7:50

Hard rebooted the router and that seems to have fixed it. I'm pretty sure the routing tables on the Pace 921VNX got all messed up when I switched from DHCP to static on one of the dices, c'est la vie.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.