Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am building a storage server with the following components:

  • U-NAS NSC-800 Server Chassis
  • ADATA Premier Pro SP600 ASP600S3-32GM-C 2.5" 32 GB SATA III MLC Internal Solid State Drive (SSD)
  • ASUS C8HM70-I/HDMI Intel Celeron BGA1023 Intel HM70 Mini ITX Motherboard/CPU/VGA Combo
  • Athena Power AP-U1ATX50 20+4Pin 500 W Single 1U EPS Server Power Supply - OEM
  • HighPoint RocketRAID 2680 8-Channel PCI-Express x4 SAS 3 Gbit/s RAID Controller

That's all good. I built the server, installed Ubuntu 12.04 LTS 32-bit on the 32 GB SSD, turned it on, ran some updates, and everything seems to work normally. Then I tried to add hard drives to the server. I don't want to set up a RAID array per se, for now I just need to connect all of the drives separately so that I can see them separately either in /dev/ or the disk utility. I don't want any pools or backups, or anything like that, just the individual drives themselves. I believe I've seen people on different forums referring to this as "using your RAID card as a SATA controller". The problem is that I went to where there are only drivers for Ubuntu 11.04 (that was the start of the problem) and looked at the installation guide.

I was hoping, in vain, that there would be no issue between Ubuntu 11.04 drivers and Ubuntu 12.04 drivers, but this was not the case. I went through the instructions in the guide, but it did not work because when I added the drives in the pre-BIOS RAID menu they did not appear to be recognized by Ubuntu. On top of this, I do not entirely understand how to just add drives to the card so that it sees them as individual drives since the pre-BIOS menu is pretty unclear.

Where do I get the Ubuntu 12.04 driver (I don't really want to go to Ubuntu 11.04, but I can if I absolutely have to), and how do I properly add the drives in such a way as to not create a RAID, but just treat them as regular drives?

I saw the post RocketRaid 26xx Driver which seems to be about something similar but for a different RAID card model.

share|improve this question
Without logs we really can't help you, I can't even tell if the driver is loaded. The highpoint is a real piece of work, it's not very well maintained, and out of tree. BIOS config should be easy, there's physical and logical disks, logical disks contain physical disks. It should be pretty straight forward and transparent to the OS as all it sees is the logical disk. Some raid controllers, if not configured show nothing. Those are all or nothing RAID controllers, they do not support direct attached mode. To mimic DA, create a RAID0 with a single disk. Some HP controllers require this hack. – ppetraki Jul 16 '13 at 19:13

The latest versions of the source code and web management tool seem to "just work" on Ubuntu 12.04.2 LTS (GNU/Linux 3.5.0-23-generic x86_64), which is wonderful news as far as I'm concerned. Steps are below, but all are trivial. The below would need to be tweaked slightly if installing on a 32 bit platform, because all of the below filenames are the 64 bit versions.

This still doesn't fix the SATA controller point though. The only way to have the card do that which I've found is to create a single-disk JBOD on each disk (which can be done in the BIOS tool). Not very elegant, but kind of works at least.

Steps to install drivers (don't forget to put in your username in the second-last step instead of the square brackets bit):

    tar -zxf RR268x-Linux-Src-v1.9-120817-1639.tar.gz
    cd rr268x-linux-src-v1.9/product/rr2680/linux/
    sudo make install
    cd ../../../..
    tar -zxf WebGUI-Linux-v2.1.5-130409.tgz
    sudo apt-get install alien
    sudo alien --script hptsvr-https-2.1.5-13.0409.x86_64.rpm #obviously use the i386 version if you're on 32 bit
    sudo dpkg -r hptsvr-https
    sudo dpkg -i hptsvr-https_2.1.5-14.0409_amd64.deb
    cd ~/Desktop/
    sudo chown [username] hptwebraid.desktop
    sudo chmod a+x hptwebraid.desktop
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.