Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to disable GNOME keyring globally on my machine. So I deleted the lines

auth    optional        pam_gnome_keyring.so
session optional        pam_gnome_keyring.so auto_start

in /etc/pam.d/gdm. It seems to me that this has no effect. When I lock in the syslog writes

Aug 24 18:37:03 foobar gnome-screensaver-dialog: gkr-pam: unlocked login keyring

and another user sees a menu window where he hs to enter his credentials. So what is the correct way to disable keyring for every user on that machine?

share|improve this question
    

2 Answers 2

up vote 8 down vote accepted

Try this: System-> Preferences-> Startup Applications and uncheck gnome-keyring-daemon.

share|improve this answer
    
This has changed to just System -> Startup Applications, in Precise 12.04 at least. –  nealmcb Oct 11 at 3:37

I think you just disabled the auto-unlock. To disable it completely, I suppose you could uninstall it. If that makes the package manager unhappy, you could also sudo chmod -x /usr/bin/gnome-keyring

share|improve this answer
    
The pam_gnome_keyring.so PAM module passes your login password to gnome-keyring after you login, which unlocks those keyrings that have the same password. Seems like marking seahorse for removal doesn't try to pull other packages with it, so removing it should be safe. –  JanC Aug 25 '10 at 1:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.