Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a notebook with an external keyboard. I want to use "German (no dead keys)" on both keyboards, but for the external, it keeps resetting if I unplug it. Actually, it does not really reset - the change is not shown in Settings -> Keyboard - but the accent keys are dead.

Strangely, I can fix that by changing the type between "Generic keyboard with 101 keys" and "Generic keyboard with 105 keys". It does not matter which one I choose, but the change triggers the keyboard layout to be applied again.

For the internal keyboard the correct layout is always applied.

I'm on XUbuntu 13.04, XFCE 4.10.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The problem seems to be that system-wide settings are not saved. In combination with the keyboard layout being reset to the system-wide setting when it is re-plugged, that reset my layout every time. So what helped me was a simple

sudo dpkg-reconfigure keyboard-configuration

which allowed me to set the system-wide keyboard layout. The UI Xubuntu provides did not help there for some reason.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.